{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-46151 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-46151 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-46151 is a medium-severity cross-site scripting vulnerability in pinterest querybook, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-46151 and fix it if it is affected.\n\nWhat it is: CVE-2022-46151 is a medium-severity cross-site scripting vulnerability in pinterest querybook, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-46151 in the wild and no public exploit code.\n\nAffected product: pinterest querybook. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46151/ (Markdown: https://insights.sbomify.com/CVE-2022-46151/index.md)","id":"CVE-2022-46151","markdown":"https://insights.sbomify.com/CVE-2022-46151/index.md","name":"CVE-2022-46151","record":{"aliases":["GHSA-mrrw-9wf7-xq6w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"Data querying UI","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via reflected XSS in the auth callback error field if CSP is disabled or unsafe-inline is allowed.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"querybook","vendor":"pinterest"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Querybook is an open source data querying UI. In affected versions user provided data is not escaped in the error field of the auth callback url in `querybook/server/app/auth/oauth_auth.py` and `querybook/server/app/auth/okta_auth.py`. This may allow attackers to perform reflected cross site scripting (XSS) if Content Security Policy (CSP) is not enabled or `unsafe-inline` is allowed. Users are advised to upgrade to the latest, patched version of querybook (version 3.14.2 or greater). Users unable to upgrade may enable CSP and not allow unsafe-inline or manually escape query parameters in a reverse proxy.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Reflected XSS","id":"CVE-2022-46151","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":2,"next":{"headline":"OP-TEE Trusted OS vulnerable to Improper Validation of Array Index in the cleanup_shm_refs function","id":"CVE-2022-46152"},"packages":[],"prev":{"headline":"Discourse may allow exposure of hidden tags in the subject of notification emails","id":"CVE-2022-46150"},"products":["querybook"],"published":"2022-12-06","related":[{"cvss_score":6.1,"headline":"Querybook Stored Cross-Site Scripting allows Privilege Elevation","id":"CVE-2024-27103","kev_date_added":null,"published":"2024-02-28"},{"cvss_score":6.1,"headline":"Querybook's Stored Cross-Site Scripting vulnerability allows Privilege Elevation","id":"CVE-2024-26148","kev_date_added":null,"published":"2024-02-21"},{"cvss_score":5.6,"headline":"Cross-site websocket hijacking in Querybook","id":"CVE-2024-28251","kev_date_added":null,"published":"2024-03-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["pinterest"]},"summary":"Attackers can execute arbitrary scripts via reflected XSS in the auth callback error field if CSP is disabled or unsafe-inline is allowed.","url":"https://insights.sbomify.com/CVE-2022-46151/"}