# CVE-2022-46151: Reflected XSS

> Attackers can execute arbitrary scripts via reflected XSS in the auth callback error field if CSP is disabled or unsafe-inline is allowed.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 6 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-mrrw-9wf7-xq6w

## What is CVE-2022-46151?

CVE-2022-46151 is a medium-severity cross-site scripting vulnerability in pinterest querybook, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Querybook is an open source data querying UI. In affected versions user provided data is not escaped in the error field of the auth callback url in `querybook/server/app/auth/oauth_auth.py` and `querybook/server/app/auth/okta_auth.py`. This may allow attackers to perform reflected cross site scripting (XSS) if Content Security Policy (CSP) is not enabled or `unsafe-inline` is allowed. Users are advised to upgrade to the latest, patched version of querybook (version 3.14.2 or greater). Users unable to upgrade may enable CSP and not allow unsafe-inline or manually escape query parameters in a reverse proxy.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-46151?

It affects 1 product.


Products: Pinterest Querybook.

## How do I fix CVE-2022-46151?

No fix has been published for CVE-2022-46151 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-46151 being exploited?

There is no known exploitation of CVE-2022-46151 in the wild and no public exploit code.

## Other vulnerabilities in pinterest querybook

- [CVE-2024-27103](https://insights.sbomify.com/CVE-2024-27103/): Querybook Stored Cross-Site Scripting allows Privilege Elevation (medium 6.1)
- [CVE-2024-26148](https://insights.sbomify.com/CVE-2024-26148/): Querybook's Stored Cross-Site Scripting vulnerability allows Privilege Elevation (medium 6.1)
- [CVE-2024-28251](https://insights.sbomify.com/CVE-2024-28251/): Cross-site websocket hijacking in Querybook (medium 5.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46151 and fix it if it is affected.

What it is: CVE-2022-46151 is a medium-severity cross-site scripting vulnerability in pinterest querybook, published on 6 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-46151 in the wild and no public exploit code.

Affected product: pinterest querybook. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46151/ (Markdown: https://insights.sbomify.com/CVE-2022-46151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46151
- OSV: https://osv.dev/vulnerability/CVE-2022-46151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46151/
Summaries are generated and may contain mistakes; the official description above is the record.
