{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-46155 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-46155 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-46155 is a high-severity vulnerability in airtable.js, published on 29 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-46155 and fix it if it is affected.\n\nWhat it is: CVE-2022-46155 is a high-severity vulnerability in airtable.js, published on 29 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-46155 in the wild and no public exploit code.\n\nAffected product: airtable.js. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46155/ (Markdown: https://insights.sbomify.com/CVE-2022-46155/index.md)","id":"CVE-2022-46155","markdown":"https://insights.sbomify.com/CVE-2022-46155/index.md","name":"CVE-2022-46155","record":{"aliases":["GHSA-vqm5-9546-x25v"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript client library","requires_auth":"high_privilege","summary":"Developers building Airtable.js from source may accidentally expose API keys in bundled code, requiring key rotation and upgrades.","user_interaction":"required","vuln_class":"hardcoded_credentials"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"airtable","vendor":"airtable"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-312","name":"Cleartext Storage of Sensitive Information"},{"id":"CWE-522","name":"Insufficiently Protected Credentials"}],"description":"Airtable.js is the JavaScript client for Airtable. Prior to version 0.11.6, Airtable.js had a misconfigured build script in its source package. When the build script is run, it would bundle environment variables into the build target of a transpiled bundle. Specifically, the AIRTABLE_API_KEY and AIRTABLE_ENDPOINT_URL environment variables are inserted during Browserify builds due to being referenced in Airtable.js code. This only affects copies of Airtable.js built from its source, not those installed via npm or yarn. Airtable API keys set in users’ environments via the AIRTABLE_API_KEY environment variable may be bundled into local copies of Airtable.js source code if all of the following conditions are met: 1) the user has cloned the Airtable.js source onto their machine, 2) the user runs the `npm prepare` script, and 3) the user' has the AIRTABLE_API_KEY environment variable set. If these conditions are met, a user’s local build of Airtable.js would be modified to include the value of the AIRTABLE_API_KEY environment variable, which could then be accidentally shipped in the bundled code. Users who do not meet all three of these conditions are not impacted by this issue. Users should upgrade to Airtable.js version 0.11.6 or higher; or, as a workaround unset the AIRTABLE_API_KEY environment variable in their shell and/or remove it from your .bashrc, .zshrc, or other shell configuration files. Users should also regenerate any Airtable API keys they use, as the keysy may be present in bundled code.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Airtable.js credentials exposed in browser builds","id":"CVE-2022-46155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"hardcoded_credentials","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Grafana's default installation of `synthetic-monitoring-agent` exposes sensitive information","id":"CVE-2022-46156"},"packages":[],"prev":{"headline":"Arbitrary file access in KodExplorer","id":"CVE-2022-46154"},"products":["airtable.js"],"published":"2022-11-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Airtable"]},"summary":"Developers building Airtable.js from source may accidentally expose API keys in bundled code, requiring key rotation and upgrades.","url":"https://insights.sbomify.com/CVE-2022-46155/"}