# CVE-2022-46155: Airtable.js credentials exposed in browser builds

> Developers building Airtable.js from source may accidentally expose API keys in bundled code, requiring key rotation and upgrades.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 29 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-vqm5-9546-x25v

## What is CVE-2022-46155?

CVE-2022-46155 is a high-severity vulnerability in airtable.js, published on 29 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Airtable.js is the JavaScript client for Airtable. Prior to version 0.11.6, Airtable.js had a misconfigured build script in its source package. When the build script is run, it would bundle environment variables into the build target of a transpiled bundle. Specifically, the AIRTABLE_API_KEY and AIRTABLE_ENDPOINT_URL environment variables are inserted during Browserify builds due to being referenced in Airtable.js code. This only affects copies of Airtable.js built from its source, not those installed via npm or yarn. Airtable API keys set in users’ environments via the AIRTABLE_API_KEY environment variable may be bundled into local copies of Airtable.js source code if all of the following conditions are met: 1) the user has cloned the Airtable.js source onto their machine, 2) the user runs the `npm prepare` script, and 3) the user' has the AIRTABLE_API_KEY environment variable set. If these conditions are met, a user’s local build of Airtable.js would be modified to include the value of the AIRTABLE_API_KEY environment variable, which could then be accidentally shipped in the bundled code. Users who do not meet all three of these conditions are not impacted by this issue. Users should upgrade to Airtable.js version 0.11.6 or higher; or, as a workaround unset the AIRTABLE_API_KEY environment variable in their shell and/or remove it from your .bashrc, .zshrc, or other shell configuration files. Users should also regenerate any Airtable API keys they use, as the keysy may be present in bundled code.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information), CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2022-46155?

It affects 1 product.


Products: Airtable Airtable.

## How do I fix CVE-2022-46155?

No fix has been published for CVE-2022-46155 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-46155 being exploited?

There is no known exploitation of CVE-2022-46155 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46155 and fix it if it is affected.

What it is: CVE-2022-46155 is a high-severity vulnerability in airtable.js, published on 29 Nov 2022. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-46155 in the wild and no public exploit code.

Affected product: airtable.js. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46155/ (Markdown: https://insights.sbomify.com/CVE-2022-46155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46155
- OSV: https://osv.dev/vulnerability/CVE-2022-46155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46155/
Summaries are generated and may contain mistakes; the official description above is the record.
