# CVE-2022-46164: Account takeover via prototype vulnerability

> Attackers can impersonate users and take over accounts in NodeBB due to improper prototype handling in socket.io messages.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-rf3g-v8p5-p675

## What is CVE-2022-46164?

CVE-2022-46164 is a critical authentication bypass vulnerability in NodeBB, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

NodeBB is an open source Node.js based forum software. Due to a plain object with a prototype being used in socket.io message handling a specially crafted payload can be used to impersonate other users and takeover accounts. This vulnerability has been patched in version 2.6.1. Users are advised to upgrade. Users unable to upgrade may cherry-pick commit `48d143921753914da45926cca6370a92ed0c46b8` into their codebase to patch the exploit.

Weakness: CWE-665 (Improper Initialization)

## Which versions are affected by CVE-2022-46164?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 2.6.1 |
| `nodebb` | npm | All versions | 2.6.1 |

Products: Nodebb Nodebb.

## How do I fix CVE-2022-46164?

Upgrade nodebb to 2.6.1 or later.

## Is CVE-2022-46164 being exploited?

There is no known exploitation of CVE-2022-46164 in the wild and no public exploit code.

Public exploit code:

- Basic POC exploit for CVE-2022-46164 (github_poc): https://github.com/stephenbradshaw/CVE-2022-46164-poc

## Other vulnerabilities in NodeBB

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-36045](https://insights.sbomify.com/CVE-2022-36045/): Account takeover via cryptographically weak PRNG in NodeBB Forum (critical 9.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46164 and fix it if it is affected.

What it is: CVE-2022-46164 is a critical authentication bypass vulnerability in NodeBB, published on 5 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46164 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 2.6.1
- nodebb (npm): affected all versions; fixed in 2.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46164/ (Markdown: https://insights.sbomify.com/CVE-2022-46164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46164
- OSV: https://osv.dev/vulnerability/CVE-2022-46164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46164/
Summaries are generated and may contain mistakes; the official description above is the record.
