# CVE-2022-46170: CodeIgniter is vulnerable to improper authentication via Session Handlers

> Attackers can bypass authentication and access admin pages by reusing user session cookies when multiple session cookies and specific session handlers are configured.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** BIT-codeigniter-2022-46170, GHSA-6cq5-8cj7-g558

## What is CVE-2022-46170?

CVE-2022-46170 is a high-severity authentication bypass vulnerability in CodeIgniter4, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. When an application uses (1) multiple session cookies (e.g., one for user pages and one for admin pages) and (2)  a session handler is set to `DatabaseHandler`, `MemcachedHandler`, or `RedisHandler`, then if an attacker gets one session cookie (e.g., one for user pages), they may be able to access pages that require another session cookie (e.g., for admin pages). This issue has been patched, please upgrade to version 4.2.11 or later. As a workaround, use only one session cookie.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-46170?

3 open source packages ship an affected version, including codeigniter4/framework and codeigniter. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.2.11 |
| `codeigniter4/framework` | Packagist | All versions | 4.2.11 |
| `codeigniter` | Bitnami | From 4.0.0 | 4.2.11 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2022-46170?

Upgrade codeigniter4/framework to 4.2.11 or later.

## Is CVE-2022-46170 being exploited?

There is no known exploitation of CVE-2022-46170 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46170 and fix it if it is affected.

What it is: CVE-2022-46170 is a high-severity authentication bypass vulnerability in CodeIgniter4, published on 22 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46170 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.11
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.2.11
- codeigniter (Bitnami): affected from 4.0.0; fixed in 4.2.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46170/ (Markdown: https://insights.sbomify.com/CVE-2022-46170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46170
- OSV: https://osv.dev/vulnerability/CVE-2022-46170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46170/
Summaries are generated and may contain mistakes; the official description above is the record.
