# CVE-2022-46172: authentik allows existing authenticated users to create arbitrary accounts

> Authenticated users can create arbitrary accounts via default flows, potentially bypassing account creation policies and affecting SSO infrastructure.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** BIT-authentik-2022-46172, GHSA-hv8r-6w7p-mpc5

## What is CVE-2022-46172?

CVE-2022-46172 is a medium-severity vulnerability in goauthentik authentik, published on 28 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

authentik is an open-source Identity provider focused on flexibility and versatility. In versions prior to 2022.10.4, and 2022.11.4, any authenticated user can create an arbitrary number of accounts through the default flows. This would circumvent any policy in a situation where it is undesirable for users to create new accounts by themselves. This may also affect other applications as these new basic accounts would exist throughout the SSO infrastructure. By default the newly created accounts cannot be logged into as no password reset exists by default. However password resets are likely to be enabled by most installations. This vulnerability pertains to the user context used in the default-user-settings-flow, /api/v3/flows/instances/default-user-settings-flow/execute/. This issue has been fixed in versions 2022.10.4 and 2022.11.4.

Weakness: CWE-287 (Improper Authentication), CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-46172?

1 open source package ship an affected version, including authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | From 2022.10.0 | 2022.10.4, 2022.11.4 |

Products: Goauthentik Authentik.

## How do I fix CVE-2022-46172?

Upgrade authentik to a fixed version for your release line: 2022.10.4 or 2022.11.4.

## Is CVE-2022-46172 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46172 exists.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46172 and fix it if it is affected.

What it is: CVE-2022-46172 is a medium-severity vulnerability in goauthentik authentik, published on 28 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46172 exists.

Affected packages and fixed versions:
- authentik (Bitnami): affected from 2022.10.0; fixed in 2022.10.4, 2022.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46172/ (Markdown: https://insights.sbomify.com/CVE-2022-46172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46172
- OSV: https://osv.dev/vulnerability/CVE-2022-46172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46172/
Summaries are generated and may contain mistakes; the official description above is the record.
