# CVE-2022-46173: Elrond go Processing: fallback search of SCRs when not found in the main cache

> A flaw in Elrond-GO causes nodes to stop notarizing metachain blocks when processing specific cross-shard transactions, leading to a denial of service.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Dec 2022
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-p228-4mrh-ww7r, GO-2022-1200

## What is CVE-2022-46173?

CVE-2022-46173 is a high-severity denial of service vulnerability in ElrondNetwork elrond-go, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Elrond-GO is a go implementation for the Elrond Network protocol. Versions prior to 1.3.50 are subject to a processing issue where nodes are affected when trying to process a cross-shard relayed transaction with a smart contract deploy transaction data. The problem was a bad correlation between the transaction caches and the processing component. If the above-mentioned transaction was sent with more gas than required, the smart contract result (SCR transaction) that should have returned the leftover gas, would have been wrongly added to a cache that the processing unit did not consider. The node stopped notarizing metachain blocks. The fix was actually to extend the SCR transaction search in all other caches if it wasn't found in the correct (expected) sharded-cache. There are no known workarounds at this time. This issue has been patched in version 1.3.50.

Weakness: CWE-669 (Incorrect Resource Transfer Between Spheres)

## Which versions are affected by CVE-2022-46173?

3 open source packages ship an affected version, including github.com/ElrondNetwork/elrond-go. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/ElrondNetwork/elrond-go` | Go | All versions | 1.3.50 |
| `github.com/ElrondNetwork/elrond-go` | Go | All versions | 1.3.50 |
| `github.com/ElrondNetwork/elrond-go` | Go | All versions | 1.3.50 |

Products: Elrond Elrond Go.

## How do I fix CVE-2022-46173?

Upgrade github.com/ElrondNetwork/elrond-go to 1.3.50 or later.

## Is CVE-2022-46173 being exploited?

There is no known exploitation of CVE-2022-46173 in the wild and no public exploit code.

## Other vulnerabilities in ElrondNetwork elrond-go

- [CVE-2022-36058](https://insights.sbomify.com/CVE-2022-36058/): elrond-go MultiESDTNFTTransfer call on a SC address with missing function name (high 7.5)
- [CVE-2022-36061](https://insights.sbomify.com/CVE-2022-36061/): Elrond go can execute on same context checks in VM (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46173 and fix it if it is affected.

What it is: CVE-2022-46173 is a high-severity denial of service vulnerability in ElrondNetwork elrond-go, published on 28 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46173 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/ElrondNetwork/elrond-go (Go): affected all versions; fixed in 1.3.50
- github.com/ElrondNetwork/elrond-go (Go): affected all versions; fixed in 1.3.50
- github.com/ElrondNetwork/elrond-go (Go): affected all versions; fixed in 1.3.50

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46173/ (Markdown: https://insights.sbomify.com/CVE-2022-46173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46173
- OSV: https://osv.dev/vulnerability/CVE-2022-46173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46173/
Summaries are generated and may contain mistakes; the official description above is the record.
