CVE-2022-46174 Race condition during concurrent TLS mounts in efs-utils
Concurrent TLS mounts in efs-utils can cause port collisions, leading to failed mounts or incorrect file system mappings.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-46174?
CVE-2022-46174 is a medium-severity vulnerability in aws efs-utils, published on 28 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
efs-utils is a set of Utilities for Amazon Elastic File System (EFS). A potential race condition issue exists within the Amazon EFS mount helper in efs-utils versions v1.34.3 and below. When using TLS to mount file systems, the mount helper allocates a local port for stunnel to receive NFS connections prior to applying the TLS tunnel. In affected versions, concurrent mount operations can allocate the same local port, leading to either failed mount operations or an inappropriate mapping from an EFS customer’s local mount points to that customer’s EFS file systems. This issue is patched in version v1.34.4. There is no recommended work around. We recommend affected users update the installed version of efs-utils to v1.34.4 or later.
Weakness: CWE-362
Which versions are affected by CVE-2022-46174?
2 open source packages ship an affected version, including github.com/kubernetes-sigs/aws-efs-csi-driver. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/kubernetes-sigs/aws-efs-csi-driver Go | All versions | 1.4.8 |
github.com/kubernetes-sigs/aws-efs-csi-driver Go | All versions | 1.4.8 |
Linux distribution packages (7)
aws-efs-utils SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 1.7-1.6.1 |
aws-efs-utils SUSE:Linux Enterprise Module for Public Cloud 15 SP1 | All versions | 1.34.5-150100.4.11.1 |
aws-efs-utils SUSE:Linux Enterprise Module for Public Cloud 15 SP2 | All versions | 1.34.5-150100.4.11.1 |
aws-efs-utils SUSE:Linux Enterprise Module for Public Cloud 15 SP3 | All versions | 1.34.5-150100.4.11.1 |
aws-efs-utils SUSE:Linux Enterprise Module for Public Cloud 15 SP4 | All versions | 1.34.5-150100.4.11.1 |
aws-efs-utils openSUSE:Leap 15.4 | All versions | 1.34.5-150100.4.11.1 |
aws-efs-utils openSUSE:Tumbleweed | All versions | 1.34.5-1.1 |
Products include Amazon Efs-Utils, Amazon Elastic File System Container Storage Interface Driver.
How do I fix CVE-2022-46174?
Upgrade github.com/kubernetes-sigs/aws-efs-csi-driver to 1.4.8 or later.
Is CVE-2022-46174 being exploited?
There is no known exploitation of CVE-2022-46174 in the wild and no public exploit code.
Sources
Also known as GHSA-4fv8-w65m-3932, SUSE-SU-2023:0423-1, SUSE-SU-2023:1761-1, openSUSE-SU-2024:12639-1.