CVE-2022-46175 Prototype Pollution in JSON5 via Parse Method
Attackers can pollute object prototypes via crafted JSON5 input, potentially leading to code execution or privilege escalation in applications using the library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-46175?
CVE-2022-46175 is a high-severity unsafe deserialization vulnerability in Fedoraproject Fedora, published on 24 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
JSON5 is an extension to the popular JSON file format that aims to be easier to write and maintain by hand (e.g. for config files). The `parse` method of the JSON5 library before and including versions 1.0.1 and 2.2.1 does not restrict parsing of keys named `__proto__`, allowing specially crafted strings to pollute the prototype of the resulting object. This vulnerability pollutes the prototype of the object returned by `JSON5.parse` and not the global Object prototype, which is the commonly understood definition of Prototype Pollution. However, polluting the prototype of a single object can have significant security impact for an application if the object is later used in trusted operations. This vulnerability could allow an attacker to set arbitrary and unexpected keys on the object returned from `JSON5.parse`. The actual impact will depend on how applications utilize the returned object and how they filter unwanted keys, but could include denial of service, cross-site scripting, elevation of privilege, and in extreme cases, remote code execution. `JSON5.parse` should restrict parsing of `__proto__` keys when parsing JSON strings to objects. As a point of reference, the `JSON.parse` method included in JavaScript ignores `__proto__` keys. Simply changing `JSON5.parse` to `JSON.parse` in the examples above mitigates this vulnerability. This vulnerability is patched in json5 versions 1.0.2, 2.2.2, and later.
Weakness: CWE-1321
Which versions are affected by CVE-2022-46175?
4 open source packages ship an affected version, including json5. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
json5 npm | All versions | 1.0.2 |
json5 npm | All versions | 1.0.2 |
json5 npm | From 2.0.0 | 2.2.2 |
json5 npm | From 2.0.0 | 2.2.2 |
Products include Fedoraproject Fedora, Json5 Json5.
How do I fix CVE-2022-46175?
Upgrade json5 to a fixed version for your release line: 1.0.2 or 2.2.2.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2022-46175 being exploited?
There is no known exploitation of CVE-2022-46175 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as AZL-44886, CLSA-2026-1773015271, CLSA-2026-1773706636, CLSA-2026-1777077480, CLSA-2026-1780879895, CLSA-2026-1792779379 and 7 more.