CVE-2022-46258 Incorrect Authorization in GitHub Enterprise Server leads to Action Workflow modifications without Workflow Scope

Medium 6.5 Published Updated

Attackers with repository-scoped tokens can modify Action Workflow files without the required Workflow scope, bypassing intended authorization controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-46258?

CVE-2022-46258 is a medium-severity missing authorization vulnerability in Github Enterprise Server, published on 9 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An incorrect authorization vulnerability was identified in GitHub Enterprise Server that allowed a repository-scoped token with read/write access to modify Action Workflow files without a Workflow scope. The Create or Update file contents API should enforce workflow scope. This vulnerability affected all versions of GitHub Enterprise Server prior to version 3.7 and was fixed in versions 3.3.16, 3.4.11, 3.5.8, and 3.6.4. This vulnerability was reported via the GitHub Bug Bounty program.

Weakness: CWE-863

Which versions are affected by CVE-2022-46258?

It affects 1 product.

Products include Github Enterprise Server.

How do I fix CVE-2022-46258?

No fix has been published for CVE-2022-46258 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2022-46258 being exploited?

There is no known exploitation of CVE-2022-46258 in the wild and no public exploit code.

All Github Enterprise Server vulnerabilities

Sources

Also known as GHSA-7x7g-xq59-cqgh.

Is CVE-2022-46258 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free