# CVE-2022-46280: Open Babel has uninitialized pointer dereference in PQS pFormat

> A use of uninitialized pointer in Open Babel allows arbitrary code execution via a specially crafted malformed file.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2023
- **Updated:** 3 Aug 2024
- **Also known as:** DEBIAN-CVE-2022-46280, GHSA-8qxc-57hf-hc9j, PYSEC-2026-2777, UBUNTU-CVE-2022-46280

## What is CVE-2022-46280?

CVE-2022-46280 is a critical memory corruption vulnerability in Open Babel, published on 21 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A use of uninitialized pointer vulnerability exists in the PQS format pFormat functionality of Open Babel 3.1.1 and master commit 530dbfa3. A specially crafted malformed file can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.

Weakness: CWE-824 (Access of Uninitialized Pointer)

## Which versions are affected by CVE-2022-46280?

3 open source packages ship an affected version, including openbabel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |
| `openbabel` | PyPI | All versions | 3.2.0 |

Products: Openbabel Open Babel.

## How do I fix CVE-2022-46280?

Upgrade openbabel to 3.2.0 or later.

## Is CVE-2022-46280 being exploited?

There is no known exploitation of CVE-2022-46280 in the wild and no public exploit code.

## Other vulnerabilities in Open Babel

- [CVE-2022-41793](https://insights.sbomify.com/CVE-2022-41793/): Open Babel has out-of-bounds write in CSR PadString (title field) (critical 9.8)
- [CVE-2022-42885](https://insights.sbomify.com/CVE-2022-42885/): Open Babel has uninitialized pointer dereference in GRO residue parser (critical 9.8)
- [CVE-2022-43467](https://insights.sbomify.com/CVE-2022-43467/): Open Babel has out-of-bounds write in PQS coord_file parser (critical 9.8)
- [CVE-2022-44451](https://insights.sbomify.com/CVE-2022-44451/): Open Babel has uninitialized pointer dereference in MSI atom parser (critical 9.8)
- [CVE-2022-46289](https://insights.sbomify.com/CVE-2022-46289/): Open Babel has out-of-bounds write in ORCA nAtoms parser (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46280 and fix it if it is affected.

What it is: CVE-2022-46280 is a critical memory corruption vulnerability in Open Babel, published on 21 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46280 in the wild and no public exploit code.

Affected packages and fixed versions:
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0
- openbabel (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46280/ (Markdown: https://insights.sbomify.com/CVE-2022-46280/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46280
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46280
- OSV: https://osv.dev/vulnerability/CVE-2022-46280

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46280/
Summaries are generated and may contain mistakes; the official description above is the record.
