CVE-2022-4632 Auto Upload Images cross site scripting

Low 3.5 Published Updated

Remote attackers can inject malicious scripts via the Auto Upload Images plugin, potentially compromising user sessions or site integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2022-4632?

CVE-2022-4632 is a low-severity cross-site scripting vulnerability in Auto Upload Images, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A vulnerability has been found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. The identifier VDB-216481 was assigned to this vulnerability.

Weakness: CWE-79

Which versions are affected by CVE-2022-4632?

It affects 1 product.

Products include Auto Upload Images Project Auto Upload Images.

How do I fix CVE-2022-4632?

No fix has been published for CVE-2022-4632 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4632 being exploited?

There is no known exploitation of CVE-2022-4632 in the wild and no public exploit code.

Sources

Also known as GHSA-gh77-92x7-j48m.

Is CVE-2022-4632 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free