{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4632 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4632 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4632 is a low-severity cross-site scripting vulnerability in Auto Upload Images, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4632 and fix it if it is affected.\n\nWhat it is: CVE-2022-4632 is a low-severity cross-site scripting vulnerability in Auto Upload Images, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4632 in the wild and no public exploit code.\n\nAffected product: Auto Upload Images. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4632/ (Markdown: https://insights.sbomify.com/CVE-2022-4632/index.md)","id":"CVE-2022-4632","markdown":"https://insights.sbomify.com/CVE-2022-4632/index.md","name":"CVE-2022-4632","record":{"aliases":["GHSA-gh77-92x7-j48m"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can inject malicious scripts via the Auto Upload Images plugin, potentially compromising user sessions or site integrity.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"auto_upload_images","vendor":"auto_upload_images_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability has been found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. The identifier VDB-216481 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Auto Upload Images cross site scripting","id":"CVE-2022-4632","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Auto Upload Images Settings setting-page.php cross-site request forgery","id":"CVE-2022-4633"},"packages":[],"prev":{"headline":"WP-Ban ban-options.php cross site scripting","id":"CVE-2022-4631"},"products":["Auto Upload Images"],"published":"2022-12-21","related":[{"cvss_score":6.1,"headline":"WordPress Auto Upload Images Plugin \u003c= 3.3 is vulnerable to Cross Site Request Forgery (CSRF)","id":"CVE-2022-42880","kev_date_added":null,"published":"2023-06-13"},{"cvss_score":4.3,"headline":"Auto Upload Images Settings setting-page.php cross-site request forgery","id":"CVE-2022-4633","kev_date_added":null,"published":"2022-12-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-19","vendors":["n/a"]},"summary":"Remote attackers can inject malicious scripts via the Auto Upload Images plugin, potentially compromising user sessions or site integrity.","url":"https://insights.sbomify.com/CVE-2022-4632/"}