# CVE-2022-4632: Auto Upload Images cross site scripting

> Remote attackers can inject malicious scripts via the Auto Upload Images plugin, potentially compromising user sessions or site integrity.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Dec 2022
- **Updated:** 19 Nov 2024
- **Also known as:** GHSA-gh77-92x7-j48m

## What is CVE-2022-4632?

CVE-2022-4632 is a low-severity cross-site scripting vulnerability in Auto Upload Images, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability has been found in Auto Upload Images up to 3.3.0 and classified as problematic. Affected by this vulnerability is an unknown functionality. The manipulation leads to cross site scripting. The attack can be launched remotely. Upgrading to version 3.3.1 is able to address this issue. The name of the patch is 895770ee93887ec78429c78ffdfb865bee6f9436. It is recommended to upgrade the affected component. The identifier VDB-216481 was assigned to this vulnerability.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-4632?

It affects 1 product.


Products: Auto Upload Images Project Auto Upload Images.

## How do I fix CVE-2022-4632?

No fix has been published for CVE-2022-4632 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-4632 being exploited?

There is no known exploitation of CVE-2022-4632 in the wild and no public exploit code.

## Other vulnerabilities in Auto Upload Images

- [CVE-2022-42880](https://insights.sbomify.com/CVE-2022-42880/): WordPress Auto Upload Images Plugin <= 3.3 is vulnerable to Cross Site Request Forgery (CSRF) (medium 6.1)
- [CVE-2022-4633](https://insights.sbomify.com/CVE-2022-4633/): Auto Upload Images Settings setting-page.php cross-site request forgery (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4632 and fix it if it is affected.

What it is: CVE-2022-4632 is a low-severity cross-site scripting vulnerability in Auto Upload Images, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4632 in the wild and no public exploit code.

Affected product: Auto Upload Images. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4632/ (Markdown: https://insights.sbomify.com/CVE-2022-4632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4632
- OSV: https://osv.dev/vulnerability/CVE-2022-4632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4632/
Summaries are generated and may contain mistakes; the official description above is the record.
