# CVE-2022-46337: Apache Derby: LDAP injection vulnerability in authenticator

> An LDAP injection flaw in Apache Derby allows attackers to bypass authentication, potentially leading to disk exhaustion, code execution, or data corruption.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Nov 2023
- **Updated:** 10 Jun 2025
- **Also known as:** DEBIAN-CVE-2022-46337, ECHO-e8be-a1ee-9416, GHSA-rcjc-c4pj-xxrp, ROOT-APP-MAVEN-CVE-2022-46337, UBUNTU-CVE-2022-46337

## What is CVE-2022-46337?

CVE-2022-46337 is a critical authentication bypass vulnerability in Apache Derby, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A cleverly devised username might bypass LDAP authentication checks. In 
LDAP-authenticated Derby installations, this could let an attacker fill 
up the disk by creating junk Derby databases. In LDAP-authenticated 
Derby installations, this could also allow the attacker to execute 
malware which was visible to and executable by the account which booted 
the Derby server. In LDAP-protected databases which weren't also 
protected by SQL GRANT/REVOKE authorization, this vulnerability could 
also let an attacker view and corrupt sensitive data and run sensitive 
database functions and procedures.

Mitigation:

Users should upgrade to Java 21 and Derby 10.17.1.0.

Alternatively, users who wish to remain on older Java versions should 
build their own Derby distribution from one of the release families to 
which the fix was backported: 10.16, 10.15, and 10.14. Those are the 
releases which correspond, respectively, with Java LTS versions 17, 11, 
and 8.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-46337?

24 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | All versions | None |
| `org.apache.derby:derby` | Maven | All versions | None |
| `org.apache.derby:derby` | Maven | From 10.1.1.0 to 10.1.3.1 | None |
| `org.apache.derby:derby` | Maven | From 10.1.1.0 to 10.1.3.1 | None |
| `org.apache.derby:derby` | Maven | From 10.10.1.1 to 10.10.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.10.1.1 to 10.10.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.14.2.0 | 10.14.2.1 |
| `org.apache.derby:derby` | Maven | From 10.14.2.0 | 10.14.2.1 |
| `org.apache.derby:derby` | Maven | From 10.15.1.3 | 10.15.2.1 |
| `org.apache.derby:derby` | Maven | From 10.15.1.3 | 10.15.2.1 |
| `org.apache.derby:derby` | Maven | From 10.16.1.1 | 10.16.1.2 |
| `org.apache.derby:derby` | Maven | From 10.16.1.1 | 10.16.1.2 |
| `org.apache.derby:derby` | Maven | From 10.2.1.6 to 10.2.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.2.1.6 to 10.2.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.3.1.4 to 10.3.3.0 | None |
| `org.apache.derby:derby` | Maven | From 10.3.1.4 to 10.3.3.0 | None |
| `org.apache.derby:derby` | Maven | From 10.4.1.3 to 10.4.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.4.1.3 to 10.4.2.0 | None |
| `org.apache.derby:derby` | Maven | From 10.5.1.1 to 10.5.3.0 | None |
| `org.apache.derby:derby` | Maven | From 10.5.1.1 to 10.5.3.0 | None |
| `org.apache.derby:derby` | Maven | From 10.6.1.0 to 10.6.2.1 | None |
| `org.apache.derby:derby` | Maven | From 10.6.1.0 to 10.6.2.1 | None |
| `org.apache.derby:derby` | Maven | From 10.8.1.2 to 10.8.3.0 | None |
| `org.apache.derby:derby` | Maven | From 10.8.1.2 to 10.8.3.0 | None |

Products: Apache Derby.

## How do I fix CVE-2022-46337?

Upgrade org.apache.derby:derby to a fixed version for your release line: 10.14.2.1, 10.15.2.1 or 10.16.1.2.

## Is CVE-2022-46337 being exploited?

There is no known exploitation of CVE-2022-46337 in the wild and no public exploit code.

## Other vulnerabilities in Apache Derby

- [CVE-2015-1832](https://insights.sbomify.com/CVE-2015-1832/): Improper Restriction of XML External Entity Reference in Apace Derby (critical 9.1)
- [CVE-2010-2232](https://insights.sbomify.com/CVE-2010-2232/): Improper Access Control in Apache Derby (high 7.5)
- [CVE-2018-1313](https://insights.sbomify.com/CVE-2018-1313/): Improper Access Control in Apache Derby (medium 5.3)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)
- [CVE-2006-7216](https://insights.sbomify.com/CVE-2006-7216/): Missing authorization in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46337 and fix it if it is affected.

What it is: CVE-2022-46337 is a critical authentication bypass vulnerability in Apache Derby, published on 20 Nov 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46337 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected all versions; no fix listed
- org.apache.derby:derby (Maven): affected all versions; no fix listed
- org.apache.derby:derby (Maven): affected from 10.1.1.0 up to 10.1.3.1; no fix listed
- org.apache.derby:derby (Maven): affected from 10.1.1.0 up to 10.1.3.1; no fix listed
- org.apache.derby:derby (Maven): affected from 10.10.1.1 up to 10.10.2.0; no fix listed
- org.apache.derby:derby (Maven): affected from 10.10.1.1 up to 10.10.2.0; no fix listed
- org.apache.derby:derby (Maven): affected from 10.14.2.0; fixed in 10.14.2.1
- org.apache.derby:derby (Maven): affected from 10.14.2.0; fixed in 10.14.2.1
- org.apache.derby:derby (Maven): affected from 10.15.1.3; fixed in 10.15.2.1
- org.apache.derby:derby (Maven): affected from 10.15.1.3; fixed in 10.15.2.1
- org.apache.derby:derby (Maven): affected from 10.16.1.1; fixed in 10.16.1.2
- org.apache.derby:derby (Maven): affected from 10.16.1.1; fixed in 10.16.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46337/ (Markdown: https://insights.sbomify.com/CVE-2022-46337/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46337
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46337
- OSV: https://osv.dev/vulnerability/CVE-2022-46337

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46337/
Summaries are generated and may contain mistakes; the official description above is the record.
