# CVE-2022-46366: Apache Tapestry prior to version 4 (EOL) allows RCE though deserialization of untrusted input

> Attackers can achieve remote code execution by exploiting unsafe deserialization in the unsupported Apache Tapestry 3.x library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-vc39-x7w6-6vj7

## What is CVE-2022-46366?

CVE-2022-46366 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 2 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tapestry 3.x allows deserialization of untrusted data, leading to remote code execution. This issue is similar to but distinct from CVE-2020-17531, which applies the the (also unsupported) 4.x version line. NOTE: This vulnerability only affects Apache Tapestry version line 3.x, which is no longer supported by the maintainer. Users are recommended to upgrade to a supported version line of Apache Tapestry.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-46366?

2 open source packages ship an affected version, including org.apache.tapestry:tapestry-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tapestry:tapestry-core` | Maven | From 3.0 | 5.0.1 |
| `org.apache.tapestry:tapestry-core` | Maven | From 3.0 | 5.0.1 |

Products: Apache Tapestry.

## How do I fix CVE-2022-46366?

Upgrade org.apache.tapestry:tapestry-core to 5.0.1 or later.

## Is CVE-2022-46366 being exploited?

There is no known exploitation of CVE-2022-46366 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tapestry

- [CVE-2021-27850](https://insights.sbomify.com/CVE-2021-27850/): Bypass of the fix for CVE-2019-0195 (critical 9.8)
- [CVE-2020-17531](https://insights.sbomify.com/CVE-2020-17531/): Deserialization flaw in EOL Tapestry 4. (critical 9.8)
- [CVE-2019-0195](https://insights.sbomify.com/CVE-2019-0195/): Deserialization of Untrusted Data in Apache Tapestry (critical 9.8)
- [CVE-2019-10071](https://insights.sbomify.com/CVE-2019-10071/): Timing attack on HMAC signature comparison in Apache Tapestry (critical 9.8)
- [CVE-2014-1972](https://insights.sbomify.com/CVE-2014-1972/): Apache Tapestry Unsafe Object Storage (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46366 and fix it if it is affected.

What it is: CVE-2022-46366 is a critical unsafe deserialization vulnerability in Apache Tapestry, published on 2 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46366 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tapestry:tapestry-core (Maven): affected from 3.0; fixed in 5.0.1
- org.apache.tapestry:tapestry-core (Maven): affected from 3.0; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46366/ (Markdown: https://insights.sbomify.com/CVE-2022-46366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46366
- OSV: https://osv.dev/vulnerability/CVE-2022-46366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46366/
Summaries are generated and may contain mistakes; the official description above is the record.
