{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4637 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-4637 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-4637 is a low-severity vulnerability in ep3-bs, published on 21 Dec 2022."},"fix_prompt":"Check this codebase for CVE-2022-4637 and fix it if it is affected.\n\nWhat it is: CVE-2022-4637 is a low-severity vulnerability in ep3-bs, published on 21 Dec 2022. \nExploitation: There is no known exploitation of CVE-2022-4637 in the wild and no public exploit code.\n\nAffected product: ep3-bs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4637/ (Markdown: https://insights.sbomify.com/CVE-2022-4637/index.md)","id":"CVE-2022-4637","markdown":"https://insights.sbomify.com/CVE-2022-4637/index.md","name":"CVE-2022-4637","record":{"aliases":["GHSA-g58q-26cc-mjqc"],"analysis":null,"analysis_generated_by":null,"assigner":"VulDB","cpe":[{"product":"ep-3_bookingsystem","vendor":"ep-3bookingsystem"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A vulnerability classified as problematic has been found in ep3-bs up to 1.7.x. This affects an unknown part. The manipulation leads to cross site scripting. It is possible to initiate the attack remotely. Upgrading to version 1.8.0 is able to address this issue. The name of the patch is ef49e709c8adecc3a83cdc6164a67162991d2213. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216495.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"ep3-bs cross site scripting","id":"CVE-2022-4637","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":null,"year":"2022"},"n_packages":0,"n_references":4,"next":{"headline":"collective.contact.widget widgets.py title cross site scripting","id":"CVE-2022-4638"},"packages":[],"prev":{"headline":"Path traversal in KVM ACR1000A-R-R2","id":"CVE-2022-4636"},"products":["ep3-bs"],"published":"2022-12-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-4637/"}