{"answers":{"affected":"3 open source packages ship an affected version, including collective.contact.widget and collective-contact-widget. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-4638 in the wild and no public exploit code.","fix":"Upgrade collective.contact.widget to 1.13 or later.","what":"CVE-2022-4638 is a low-severity cross-site scripting vulnerability in unspecified collective.contact.widget, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-4638 and fix it if it is affected.\n\nWhat it is: CVE-2022-4638 is a low-severity cross-site scripting vulnerability in unspecified collective.contact.widget, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-4638 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- collective.contact.widget (PyPI): affected all versions; fixed in 1.13\n- collective-contact-widget (PyPI): affected all versions; fixed in 1.12\n- collective-contact-widget (PyPI): affected all versions; fixed in 1.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4638/ (Markdown: https://insights.sbomify.com/CVE-2022-4638/index.md)","id":"CVE-2022-4638","markdown":"https://insights.sbomify.com/CVE-2022-4638/index.md","name":"CVE-2022-4638","record":{"aliases":["GHSA-5pqf-rvm7-3wgw","PYSEC-2022-42988"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python contact widget","requires_auth":"low_privilege","summary":"Remote attackers can execute arbitrary scripts via the title field in collective.contact.widget, requiring a patch to mitigate.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"collective.contact.widget","vendor":"collective.contact.widget_project"}],"cvss":{"score":3.5,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"collective.contact.widget widgets.py title cross site scripting","id":"CVE-2022-4638","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"sslh Packet Dumping probe.c hexdump format string","id":"CVE-2022-4639"},"packages":[{"ecosystem":"PyPI","fixed":["1.12"],"introduced":["0"],"last_affected":[],"package":"collective-contact-widget","purl":"pkg:pypi/collective-contact-widget","source":"PYSEC-2022-42988"},{"ecosystem":"PyPI","fixed":["1.13"],"introduced":["0"],"last_affected":[],"package":"collective-contact-widget","purl":"pkg:pypi/collective-contact-widget","source":"GHSA-5pqf-rvm7-3wgw"},{"ecosystem":"PyPI","fixed":["1.13"],"introduced":["0"],"last_affected":[],"package":"collective.contact.widget","purl":null,"source":"GHSA-5pqf-rvm7-3wgw"}],"prev":{"headline":"ep3-bs cross site scripting","id":"CVE-2022-4637"},"products":["collective.contact.widget"],"published":"2022-12-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-14","vendors":["unspecified"]},"summary":"Remote attackers can execute arbitrary scripts via the title field in collective.contact.widget, requiring a patch to mitigate.","url":"https://insights.sbomify.com/CVE-2022-4638/"}