# CVE-2022-4638: collective.contact.widget widgets.py title cross site scripting

> Remote attackers can execute arbitrary scripts via the title field in collective.contact.widget, requiring a patch to mitigate.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Dec 2022
- **Updated:** 14 Apr 2025
- **Also known as:** GHSA-5pqf-rvm7-3wgw, PYSEC-2022-42988

## What is CVE-2022-4638?

CVE-2022-4638 is a low-severity cross-site scripting vulnerability in unspecified collective.contact.widget, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability classified as problematic was found in collective.contact.widget up to 1.12. This vulnerability affects the function title of the file src/collective/contact/widget/widgets.py. The manipulation leads to cross site scripting. The attack can be initiated remotely. The name of the patch is 5da36305ca7ed433782be8901c47387406fcda12. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-216496.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-4638?

3 open source packages ship an affected version, including collective.contact.widget and collective-contact-widget. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `collective.contact.widget` | PyPI | All versions | 1.13 |
| `collective-contact-widget` | PyPI | All versions | 1.12 |
| `collective-contact-widget` | PyPI | All versions | 1.13 |

Products: Collective.contact.widget Project Collective.contact.widget.

## How do I fix CVE-2022-4638?

Upgrade collective.contact.widget to 1.13 or later.

## Is CVE-2022-4638 being exploited?

There is no known exploitation of CVE-2022-4638 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4638 and fix it if it is affected.

What it is: CVE-2022-4638 is a low-severity cross-site scripting vulnerability in unspecified collective.contact.widget, published on 21 Dec 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-4638 in the wild and no public exploit code.

Affected packages and fixed versions:
- collective.contact.widget (PyPI): affected all versions; fixed in 1.13
- collective-contact-widget (PyPI): affected all versions; fixed in 1.12
- collective-contact-widget (PyPI): affected all versions; fixed in 1.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4638/ (Markdown: https://insights.sbomify.com/CVE-2022-4638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4638
- OSV: https://osv.dev/vulnerability/CVE-2022-4638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4638/
Summaries are generated and may contain mistakes; the official description above is the record.
