# CVE-2022-46405: Denial of service in n/a

> Attackers can cause denial of service in Mastodon by creating bot accounts that trigger uncontrolled recursion in the Sidekiq pull queue.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Dec 2022
- **Updated:** 24 Apr 2025
- **Also known as:** BIT-mastodon-2022-46405, GHSA-8f7g-vmw6-89m7

## What is CVE-2022-46405?

CVE-2022-46405 is a high-severity denial of service vulnerability in n/a, published on 4 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon through 4.0.2 allows attackers to cause a denial of service (large Sidekiq pull queue) by creating bot accounts that follow attacker-controlled accounts on certain other servers associated with a wildcard DNS A record, such that there is uncontrolled recursion of attacker-generated messages.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2022-46405?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | All versions | 4.0.3 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2022-46405?

Upgrade mastodon to 4.0.3 or later.

## Is CVE-2022-46405 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46405 exists.

## Other vulnerabilities in n/a

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2024-23832](https://insights.sbomify.com/CVE-2024-23832/): Mastodon Remote user impersonation and takeover (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46405 and fix it if it is affected.

What it is: CVE-2022-46405 is a high-severity denial of service vulnerability in n/a, published on 4 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46405 exists.

Affected packages and fixed versions:
- mastodon (Bitnami): affected all versions; fixed in 4.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46405/ (Markdown: https://insights.sbomify.com/CVE-2022-46405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46405
- OSV: https://osv.dev/vulnerability/CVE-2022-46405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46405/
Summaries are generated and may contain mistakes; the official description above is the record.
