{"answers":{"affected":"3 open source packages ship an affected version, including apache-airflow-providers-apache-hive. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-46421 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-hive to 5.0.0 or later.","what":"CVE-2022-46421 is a critical command injection vulnerability in Apache Airflow Hive Provider, published on 20 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-46421 and fix it if it is affected.\n\nWhat it is: CVE-2022-46421 is a critical command injection vulnerability in Apache Airflow Hive Provider, published on 20 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-46421 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.0.0\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.0.0\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 5.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46421/ (Markdown: https://insights.sbomify.com/CVE-2022-46421/index.md)","id":"CVE-2022-46421","markdown":"https://insights.sbomify.com/CVE-2022-46421/index.md","name":"CVE-2022-46421","record":{"aliases":["GHSA-rc58-qr9j-cpgw","PYSEC-2026-274"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Airflow Hive Provider","requires_auth":"none","summary":"Attackers can execute arbitrary commands via improper neutralization in the Apache Airflow Hive Provider, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"apache-airflow-providers-apache-hive","vendor":"apache"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"Improper Neutralization of Special Elements used in a Command ('Command Injection') vulnerability in Apache Software Foundation Apache Airflow Hive Provider.This issue affects Apache Airflow Hive Provider: before 5.0.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Hive Provider: Hive Provider RCE vulnerability with hive_cli_params","id":"CVE-2022-46421","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2022-46422"},"packages":[{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":null,"source":"GHSA-rc58-qr9j-cpgw"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"GHSA-rc58-qr9j-cpgw"},{"ecosystem":"PyPI","fixed":["5.0.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"PYSEC-2026-274"}],"prev":{"headline":"This CVE ID has been rejected or withdrawn by its CVE Numbering Authority because it is Unused","id":"CVE-2022-46419"},"products":["Apache Airflow Hive Provider"],"published":"2022-12-20","related":[{"cvss_score":9.8,"headline":"Apache Airflow Hive Provider Beeline RCE with Principal","id":"CVE-2023-35797","kev_date_added":null,"published":"2023-07-03"},{"cvss_score":9.8,"headline":"Apache Airflow Hive Provider Beeline RCE","id":"CVE-2023-25696","kev_date_added":null,"published":"2023-02-24"},{"cvss_score":8.8,"headline":"Apache Airflow Apache Hive Provider: Improper Input Validation in Hive Provider with proxy_user","id":"CVE-2023-37415","kev_date_added":null,"published":"2023-07-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-16","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary commands via improper neutralization in the Apache Airflow Hive Provider, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2022-46421/"}