{"answers":{"affected":"2 open source packages ship an affected version, including git. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-46648 in the wild and no public exploit code.","fix":"Upgrade git to 1.13.0 or later.","what":"CVE-2022-46648 is a high-severity code injection vulnerability in Debian Debian Linux, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-46648 and fix it if it is affected.\n\nWhat it is: CVE-2022-46648 is a high-severity code injection vulnerability in Debian Debian Linux, published on 17 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-46648 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- git (RubyGems): affected from 1.2.0; fixed in 1.13.0\n- git (RubyGems): affected from 1.2.0; fixed in 1.13.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46648/ (Markdown: https://insights.sbomify.com/CVE-2022-46648/index.md)","id":"CVE-2022-46648","markdown":"https://insights.sbomify.com/CVE-2022-46648/index.md","name":"CVE-2022-46648","record":{"aliases":["DEBIAN-CVE-2022-46648","GHSA-pfpr-3463-c6jh","UBUNTU-CVE-2022-46648"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Git library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary Ruby code by tricking a user into loading a repository with a specially crafted filename.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jpcert","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"ruby-git","vendor":"ruby-git_project"}],"cvss":{"score":8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"ruby-git versions prior to v1.13.0 allows a remote authenticated attacker to execute an arbitrary ruby code by having a user to load a repository containing a specially crafted filename to the product. This vulnerability is different from CVE-2022-47318.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ruby-git has potential remote code execution vulnerability","id":"CVE-2022-46648","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Command injection in ALEOS","id":"CVE-2022-46649"},"packages":[{"ecosystem":"RubyGems","fixed":["1.13.0"],"introduced":["1.2.0"],"last_affected":[],"package":"git","purl":null,"source":"GHSA-pfpr-3463-c6jh"},{"ecosystem":"RubyGems","fixed":["1.13.0"],"introduced":["1.2.0"],"last_affected":[],"package":"git","purl":"pkg:gem/git","source":"GHSA-pfpr-3463-c6jh"}],"prev":{"headline":"Information disclosure in Intel Unison software","id":"CVE-2022-46647"},"products":["ruby-git"],"published":"2023-01-17","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-04","vendors":["ruby-git"]},"summary":"An attacker can execute arbitrary Ruby code by tricking a user into loading a repository with a specially crafted filename.","url":"https://insights.sbomify.com/CVE-2022-46648/"}