{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:plot. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-46682 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:plot to 2.1.12 or later.","what":"CVE-2022-46682 is a critical vulnerability in Jenkins Plot Plugin, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-46682 and fix it if it is affected.\n\nWhat it is: CVE-2022-46682 is a critical vulnerability in Jenkins Plot Plugin, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-46682 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:plot (Maven): affected all versions; fixed in 2.1.12\n- org.jenkins-ci.plugins:plot (Maven): affected all versions; fixed in 2.1.12\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46682/ (Markdown: https://insights.sbomify.com/CVE-2022-46682/index.md)","id":"CVE-2022-46682","markdown":"https://insights.sbomify.com/CVE-2022-46682/index.md","name":"CVE-2022-46682","record":{"aliases":["GHSA-wgpp-g6v9-7hxp"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Plot Plugin","requires_auth":"none","summary":"Attackers can exploit XML external entity vulnerabilities in the Jenkins Plot Plugin to read sensitive files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"plot","vendor":"jenkins"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Plot Plugin XML External Entity Reference vulnerability","id":"CVE-2022-46682","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Google Login Plugin Open Redirect vulnerability","id":"CVE-2022-46683"},"packages":[{"ecosystem":"Maven","fixed":["2.1.12"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:plot","purl":null,"source":"GHSA-wgpp-g6v9-7hxp"},{"ecosystem":"Maven","fixed":["2.1.12"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:plot","purl":"pkg:maven/org.jenkins-ci.plugins/plot","source":"GHSA-wgpp-g6v9-7hxp"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2022-46681"},"products":["Jenkins Plot Plugin"],"published":"2022-12-07","related":[{"cvss_score":5.4,"headline":"Cross-site Scripting in Jenkins Plot Plugin","id":"CVE-2022-34783","kev_date_added":null,"published":"2022-06-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Jenkins Project"]},"summary":"Attackers can exploit XML external entity vulnerabilities in the Jenkins Plot Plugin to read sensitive files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2022-46682/"}