# CVE-2022-46682: Jenkins Plot Plugin XML External Entity Reference vulnerability

> Attackers can exploit XML external entity vulnerabilities in the Jenkins Plot Plugin to read sensitive files or cause denial of service.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-wgpp-g6v9-7hxp

## What is CVE-2022-46682?

CVE-2022-46682 is a critical vulnerability in Jenkins Plot Plugin, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Jenkins Plot Plugin 2.1.11 and earlier does not configure its XML parser to prevent XML external entity (XXE) attacks.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2022-46682?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:plot. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:plot` | Maven | All versions | 2.1.12 |
| `org.jenkins-ci.plugins:plot` | Maven | All versions | 2.1.12 |

Products: Jenkins Plot.

## How do I fix CVE-2022-46682?

Upgrade org.jenkins-ci.plugins:plot to 2.1.12 or later.

## Is CVE-2022-46682 being exploited?

There is no known exploitation of CVE-2022-46682 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Plot Plugin

- [CVE-2022-34783](https://insights.sbomify.com/CVE-2022-34783/): Cross-site Scripting in Jenkins Plot Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46682 and fix it if it is affected.

What it is: CVE-2022-46682 is a critical vulnerability in Jenkins Plot Plugin, published on 7 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46682 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:plot (Maven): affected all versions; fixed in 2.1.12
- org.jenkins-ci.plugins:plot (Maven): affected all versions; fixed in 2.1.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46682/ (Markdown: https://insights.sbomify.com/CVE-2022-46682/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46682
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46682
- OSV: https://osv.dev/vulnerability/CVE-2022-46682

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46682/
Summaries are generated and may contain mistakes; the official description above is the record.
