# CVE-2022-46685: Jenkins Gitea Plugin vulnerable to Cleartext Transmission of Sensitive Information

> Attackers can read exposed Gitea personal access tokens from build logs due to missing credential masking in the Jenkins plugin.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-gitea-2022-46685, GHSA-x3qh-53qf-jxq9

## What is CVE-2022-46685?

CVE-2022-46685 is a medium-severity vulnerability in Gitea Gitea, published on 7 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

In Jenkins Gitea Plugin 1.4.4 and earlier, the implementation of Gitea personal access tokens did not support credentials masking, potentially exposing them through the build log.

Weakness: CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2022-46685?

3 open source packages ship an affected version, including org.jenkins-ci.plugins:gitea and gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gitea` | Maven | All versions | 1.4.5 |
| `org.jenkins-ci.plugins:gitea` | Maven | All versions | 1.4.5 |
| `gitea` | Bitnami | All versions | 1.4.5 |

Products: Gitea Gitea.

## How do I fix CVE-2022-46685?

Upgrade org.jenkins-ci.plugins:gitea to 1.4.5 or later.

## Is CVE-2022-46685 being exploited?

There is no known exploitation of CVE-2022-46685 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46685 and fix it if it is affected.

What it is: CVE-2022-46685 is a medium-severity vulnerability in Gitea Gitea, published on 7 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46685 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gitea (Maven): affected all versions; fixed in 1.4.5
- org.jenkins-ci.plugins:gitea (Maven): affected all versions; fixed in 1.4.5
- gitea (Bitnami): affected all versions; fixed in 1.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46685/ (Markdown: https://insights.sbomify.com/CVE-2022-46685/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46685
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46685
- OSV: https://osv.dev/vulnerability/CVE-2022-46685

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46685/
Summaries are generated and may contain mistakes; the official description above is the record.
