{"answers":{"affected":"3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46741 exists.","fix":"Upgrade paddlepaddle to 2.4 or later.","what":"CVE-2022-46741 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 7 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-46741 and fix it if it is affected.\n\nWhat it is: CVE-2022-46741 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 7 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46741 exists.\n\nAffected packages and fixed versions:\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n- paddlepaddle (PyPI): affected all versions; fixed in 2.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-46741/ (Markdown: https://insights.sbomify.com/CVE-2022-46741/index.md)","id":"CVE-2022-46741","markdown":"https://insights.sbomify.com/CVE-2022-46741/index.md","name":"CVE-2022-46741","record":{"aliases":["GHSA-2hvc-hwg3-hpvw","PYSEC-2026-441"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"PaddlePaddle ML library","requires_auth":"none","summary":"An out-of-bounds read in PaddlePaddle allows attackers to cause denial of service or disclose sensitive memory contents.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Baidu","cpe":[{"product":"paddlepaddle","vendor":"paddlepaddle"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"Out-of-bounds read in gather_tree in PaddlePaddle before 2.4.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"PaddlePaddle Out-of-bounds Read vulnerability","id":"CVE-2022-46741","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"memory_corruption","year":"2022"},"n_packages":3,"n_references":1,"next":{"headline":"PaddlePaddle vulnerable to Code Injection","id":"CVE-2022-46742"},"packages":[{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":null,"source":"GHSA-2hvc-hwg3-hpvw"},{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"GHSA-2hvc-hwg3-hpvw"},{"ecosystem":"PyPI","fixed":["2.4"],"introduced":["0"],"last_affected":[],"package":"paddlepaddle","purl":"pkg:pypi/paddlepaddle","source":"PYSEC-2026-441"}],"prev":{"headline":"Denial of service in WS7100-20","id":"CVE-2022-46740"},"products":["PaddlePaddle"],"published":"2022-12-07","related":[{"cvss_score":10,"headline":"PaddlePaddle vulnerable to Code Injection","id":"CVE-2022-46742","kev_date_added":null,"published":"2022-12-07"},{"cvss_score":9.8,"headline":"PaddlePaddle vulnerable to code injection via winstr","id":"CVE-2022-45908","kev_date_added":null,"published":"2022-11-26"},{"cvss_score":9.6,"headline":"Command injection in get_online_pass_interval","id":"CVE-2023-52310","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in _wget_download","id":"CVE-2023-52311","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in convert_shape_compare","id":"CVE-2023-52314","kev_date_added":null,"published":"2024-01-03"},{"cvss_score":9.6,"headline":"Command injection in fs.py","id":"CVE-2023-38673","kev_date_added":null,"published":"2023-07-26"},{"cvss_score":9.4,"headline":"PaddlePaddle vulnerable to remote code execution","id":"CVE-2024-0917","kev_date_added":null,"published":"2024-03-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["PaddlePaddle"]},"summary":"An out-of-bounds read in PaddlePaddle allows attackers to cause denial of service or disclose sensitive memory contents.","url":"https://insights.sbomify.com/CVE-2022-46741/"}