# CVE-2022-46741: PaddlePaddle Out-of-bounds Read vulnerability

> An out-of-bounds read in PaddlePaddle allows attackers to cause denial of service or disclose sensitive memory contents.

- **Severity:** High 7.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Dec 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-2hvc-hwg3-hpvw, PYSEC-2026-441

## What is CVE-2022-46741?

CVE-2022-46741 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 7 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Out-of-bounds read in gather_tree in PaddlePaddle before 2.4.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2022-46741?

3 open source packages ship an affected version, including paddlepaddle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `paddlepaddle` | PyPI | All versions | 2.4 |
| `paddlepaddle` | PyPI | All versions | 2.4 |
| `paddlepaddle` | PyPI | All versions | 2.4 |

Products: Paddlepaddle Paddlepaddle.

## How do I fix CVE-2022-46741?

Upgrade paddlepaddle to 2.4 or later.

## Is CVE-2022-46741 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46741 exists.

## Other vulnerabilities in PaddlePaddle

- [CVE-2022-46742](https://insights.sbomify.com/CVE-2022-46742/): PaddlePaddle vulnerable to Code Injection (critical 10.0)
- [CVE-2022-45908](https://insights.sbomify.com/CVE-2022-45908/): PaddlePaddle vulnerable to code injection via winstr (critical 9.8)
- [CVE-2023-52310](https://insights.sbomify.com/CVE-2023-52310/): Command injection in get_online_pass_interval (critical 9.6)
- [CVE-2023-52311](https://insights.sbomify.com/CVE-2023-52311/): Command injection in _wget_download (critical 9.6)
- [CVE-2023-52314](https://insights.sbomify.com/CVE-2023-52314/): Command injection in convert_shape_compare (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46741 and fix it if it is affected.

What it is: CVE-2022-46741 is a high-severity memory corruption vulnerability in PaddlePaddle, published on 7 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46741 exists.

Affected packages and fixed versions:
- paddlepaddle (PyPI): affected all versions; fixed in 2.4
- paddlepaddle (PyPI): affected all versions; fixed in 2.4
- paddlepaddle (PyPI): affected all versions; fixed in 2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46741/ (Markdown: https://insights.sbomify.com/CVE-2022-46741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46741
- OSV: https://osv.dev/vulnerability/CVE-2022-46741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46741/
Summaries are generated and may contain mistakes; the official description above is the record.
