CVE-2022-46792 Missing authorization in n/a
Attackers can bypass row-level authorization in the Update Many API to modify unauthorized data in Postgres backends.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2022-46792?
CVE-2022-46792 is a high-severity missing authorization vulnerability in n/a, published on 8 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)
Weakness: CWE-863
Which versions are affected by CVE-2022-46792?
It affects 1 product.
Products include Hasura Graphql Engine.
How do I fix CVE-2022-46792?
No fix has been published for CVE-2022-46792 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-46792 being exploited?
There is no known exploitation of CVE-2022-46792 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2021-47748 Hasura GraphQL 1.3.3 - Remote Code Execution
- CVE-2021-47713 Hasura GraphQL 1.3.3 Denial of Service via Malicious GraphQL Query
- CVE-2023-27588 Unauthenticated path traversal vulnerability in Hasura GraphQL Engine
- CVE-2019-1020015 Auth bypass in graphql-engine
- CVE-2021-47714 Hasura GraphQL 1.3.3 Local File Read via SQL Injection
Sources
Also known as GHSA-g7mj-g7f4-hgrg, GHSA-jfv6-7jf3-3v86.