# CVE-2022-46792: Missing authorization in n/a

> Attackers can bypass row-level authorization in the Update Many API to modify unauthorized data in Postgres backends.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 8 Dec 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-g7mj-g7f4-hgrg, GHSA-jfv6-7jf3-3v86

## What is CVE-2022-46792?

CVE-2022-46792 is a high-severity missing authorization vulnerability in n/a, published on 8 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Hasura GraphQL Engine before 2.15.2 mishandles row-level authorization in the Update Many API for Postgres backends. The fixed versions are 2.10.2, 2.11.3, 2.12.1, 2.13.2, 2.14.1, and 2.15.2. (Versions before 2.10.0 are unaffected.)

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-46792?

It affects 1 product.


Products: Hasura Graphql Engine.

## How do I fix CVE-2022-46792?

No fix has been published for CVE-2022-46792 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-46792 being exploited?

There is no known exploitation of CVE-2022-46792 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-47748](https://insights.sbomify.com/CVE-2021-47748/): Hasura GraphQL 1.3.3 - Remote Code Execution (critical 9.3)
- [CVE-2021-47713](https://insights.sbomify.com/CVE-2021-47713/): Hasura GraphQL 1.3.3 Denial of Service via Malicious GraphQL Query (high 8.7)
- [CVE-2023-27588](https://insights.sbomify.com/CVE-2023-27588/): Unauthenticated path traversal vulnerability in Hasura GraphQL Engine (high 7.5)
- [CVE-2019-1020015](https://insights.sbomify.com/CVE-2019-1020015/): Auth bypass in graphql-engine (high 7.5)
- [CVE-2021-47714](https://insights.sbomify.com/CVE-2021-47714/): Hasura GraphQL 1.3.3 Local File Read via SQL Injection (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46792 and fix it if it is affected.

What it is: CVE-2022-46792 is a high-severity missing authorization vulnerability in n/a, published on 8 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-46792 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46792/ (Markdown: https://insights.sbomify.com/CVE-2022-46792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46792
- OSV: https://osv.dev/vulnerability/CVE-2022-46792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46792/
Summaries are generated and may contain mistakes; the official description above is the record.
