# CVE-2022-46908: Security feature bypass in n/a

> SQLite fails to enforce prohibited function restrictions in safe mode, allowing attackers to execute arbitrary file writes via UDFs.

- **Severity:** High 7.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Dec 2022
- **Updated:** 14 Oct 2026
- **Also known as:** AZL-11586, BELL-CVE-2022-46908, BIT-sqlite-2022-46908, DEBIAN-CVE-2022-46908, GHSA-993x-6558-2xmj, MGASA-2023-0094, OESA-2022-2146, OESA-2023-1219, SUSE-SU-2022:4603-1, SUSE-SU-2022:4628-1, SUSE-SU-2023:1295-1, SUSE-SU-2023:2668-1, UBUNTU-CVE-2022-46908, openSUSE-SU-2024:12574-1

## What is CVE-2022-46908?

CVE-2022-46908 is a high-severity vulnerability in Sqlite Sqlite, published on 12 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

SQLite through 3.40.0, when relying on --safe for execution of an untrusted CLI script, does not properly implement the azProhibitedFunctions protection mechanism, and instead allows UDF functions such as WRITEFILE.

## Which versions are affected by CVE-2022-46908?

1 open source package ship an affected version, including sqlite. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sqlite` | Bitnami | From 3.37.0 | 3.40.1 |
| `sqlite3` | SUSE:Enterprise Storage 7 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Enterprise Storage 7.1 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise High Performance Computing 15 SP1-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Micro 5.1 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Micro 5.2 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Micro 5.3 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 12 SP2-BCL | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 12 SP4-ESPOS | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 12 SP4-LTSS | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 15 SP1-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Linux Enterprise Server for SAP Applications 15 SP1 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Linux Enterprise Software Development Kit 12 SP5 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:Manager Proxy 4.2 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:Manager Server 4.2 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | SUSE:OpenStack Cloud 9 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 3.39.3-9.26.1 |
| `sqlite3` | openSUSE:Leap 15.3 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | openSUSE:Leap 15.4 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | openSUSE:Leap Micro 5.2 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | openSUSE:Leap Micro 5.3 | All versions | 3.39.3-150000.3.20.1 |
| `sqlite3` | openSUSE:Tumbleweed | All versions | 3.40.0-2.1 |

Products: Sqlite Sqlite.

## How do I fix CVE-2022-46908?

Upgrade sqlite to 3.40.1 or later.

## Is CVE-2022-46908 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46908 exists.

## Other vulnerabilities in Sqlite Sqlite

- [CVE-2015-5895](https://insights.sbomify.com/CVE-2015-5895/): Other in n/a (critical 10.0)
- [CVE-2017-10989](https://insights.sbomify.com/CVE-2017-10989/): Memory corruption in n/a (critical 9.8)
- [CVE-2026-11822](https://insights.sbomify.com/CVE-2026-11822/): SQLite before 3.53.2 Memory Corruption in FTS5 Extension (high 8.5)
- [CVE-2026-11824](https://insights.sbomify.com/CVE-2026-11824/): SQLite before 3.53.2 Heap Buffer Overflow via FTS5 fts5ChunkIterate (high 8.5)
- [CVE-2025-70873](https://insights.sbomify.com/CVE-2025-70873/): Information disclosure in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-46908 and fix it if it is affected.

What it is: CVE-2022-46908 is a high-severity vulnerability in Sqlite Sqlite, published on 12 Dec 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-46908 exists.

Affected packages and fixed versions:
- sqlite (Bitnami): affected from 3.37.0; fixed in 3.40.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-46908/ (Markdown: https://insights.sbomify.com/CVE-2022-46908/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-46908
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-46908
- OSV: https://osv.dev/vulnerability/CVE-2022-46908

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-46908/
Summaries are generated and may contain mistakes; the official description above is the record.
