{"answers":{"affected":"2 open source packages ship an affected version, including github.com/usememos/memos. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4695 exists.","fix":"Upgrade github.com/usememos/memos to 0.9.0 or later.","what":"CVE-2022-4695 is a high-severity cross-site scripting vulnerability in Usememos Memos, published on 23 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-4695 and fix it if it is affected.\n\nWhat it is: CVE-2022-4695 is a high-severity cross-site scripting vulnerability in Usememos Memos, published on 23 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4695 exists.\n\nAffected packages and fixed versions:\n- github.com/usememos/memos (Go): affected all versions; fixed in 0.9.0\n- github.com/usememos/memos (Go): affected all versions; fixed in 0.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4695/ (Markdown: https://insights.sbomify.com/CVE-2022-4695/index.md)","id":"CVE-2022-4695","markdown":"https://insights.sbomify.com/CVE-2022-4695/index.md","name":"CVE-2022-4695","record":{"aliases":["GHSA-c2v4-8r9g-g5xj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Memos note-taking app","requires_auth":"low_privilege","summary":"Stored XSS in usememos allows attackers to inject malicious scripts, potentially leading to code execution or account takeover.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntrdev","cpe":[{"product":"memos","vendor":"usememos"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site Scripting (XSS) - Stored in GitHub repository usememos/memos prior to 0.9.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site Scripting (XSS) - Stored in usememos/memos","id":"CVE-2022-4695","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":"usememos:memos","products":["usememos:memos"],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Use after free in Linux Kernel","id":"CVE-2022-4696"},"packages":[{"ecosystem":"Go","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"github.com/usememos/memos","purl":null,"source":"GHSA-c2v4-8r9g-g5xj"},{"ecosystem":"Go","fixed":["0.9.0"],"introduced":["0"],"last_affected":[],"package":"github.com/usememos/memos","purl":"pkg:golang/github.com/usememos/memos","source":"GHSA-c2v4-8r9g-g5xj"}],"prev":{"headline":"Cross-site Scripting (XSS) - Stored in usememos/memos","id":"CVE-2022-4694"},"products":["usememos/memos"],"published":"2022-12-23","related":[{"cvss_score":9.8,"headline":"Memos has Cross-Site Scripting (XSS) Vulnerability in Image URLs","id":"CVE-2025-50738","kev_date_added":null,"published":"2025-07-29"},{"cvss_score":9.8,"headline":"Memos Server-Side Request Forgery (SSRF)","id":"CVE-2025-22952","kev_date_added":null,"published":"2025-02-27"},{"cvss_score":9.8,"headline":"Stored XSS in usememos/memos","id":"CVE-2023-0109","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":9.8,"headline":"Improper Access Control in usememos/memos","id":"CVE-2023-4696","kev_date_added":null,"published":"2023-09-01"},{"cvss_score":9.8,"headline":"Cross-site Scripting (XSS) - Stored in usememos/memos","id":"CVE-2022-4866","kev_date_added":null,"published":"2022-12-31"},{"cvss_score":9.8,"headline":"Improper Handling of Values in usememos/memos","id":"CVE-2022-4851","kev_date_added":null,"published":"2022-12-29"},{"cvss_score":9.8,"headline":"Improper Restriction of Excessive Authentication Attempts in usememos/memos","id":"CVE-2022-4797","kev_date_added":null,"published":"2022-12-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-09","vendors":["usememos"]},"summary":"Stored XSS in usememos allows attackers to inject malicious scripts, potentially leading to code execution or account takeover.","url":"https://insights.sbomify.com/CVE-2022-4695/"}