CVE-2022-47015 Null dereference in n/a
A null pointer dereference in MariaDB Server allows attackers to cause a denial of service via the spider_db_mbase::print_warnings function.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-47015?
CVE-2022-47015 is a medium-severity vulnerability in Mariadb Mariadb, published on 20 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
MariaDB Server before 10.3.34 thru 10.9.3 is vulnerable to Denial of Service. It is possible for function spider_db_mbase::print_warnings to dereference a null pointer.
Weakness: CWE-476
Which versions are affected by CVE-2022-47015?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.3.0 | 10.3.39, 10.4.29, 10.5.20, 10.6.13, 10.8.8, 10.9.6, 10.10.4, 10.11.3 |
mariadb-min Bitnami | From 10.3.0 | 10.3.39, 10.4.29, 10.5.20, 10.6.13, 10.8.8, 10.9.6, 10.10.4, 10.11.3 |
mysql-client Bitnami | From 10.3.0 | 10.3.39, 10.4.29, 10.5.20, 10.6.13, 10.8.8, 10.9.6, 10.10.4, 10.11.3 |
Linux distribution packages (27)
mariadb SUSE:Enterprise Storage 7 | All versions | 10.4.31-150200.3.45.1 |
mariadb SUSE:Enterprise Storage 7.1 | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Enterprise Storage 7.1 | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP2-LTSS | All versions | 10.4.31-150200.3.45.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-ESPOS | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Linux Enterprise High Performance Computing 15 SP3-LTSS | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 10.6.13-150400.3.23.1 |
mariadb SUSE:Linux Enterprise Module for Package Hub 15 SP5 | All versions | 10.6.13-150400.3.23.1 |
mariadb SUSE:Linux Enterprise Module for Server Applications 15 SP4 | All versions | 10.6.13-150400.3.23.1 |
mariadb SUSE:Linux Enterprise Module for Server Applications 15 SP5 | All versions | 10.6.13-150400.3.23.1 |
mariadb SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Linux Enterprise Real Time 15 SP3 | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Linux Enterprise Server 15 SP2-LTSS | All versions | 10.4.31-150200.3.45.1 |
mariadb SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Linux Enterprise Server 15 SP3-LTSS | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP2 | All versions | 10.4.31-150200.3.45.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Linux Enterprise Server for SAP Applications 15 SP3 | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Manager Proxy 4.2 | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Manager Proxy 4.2 | All versions | 10.5.21-150300.3.32.5 |
mariadb SUSE:Manager Server 4.2 | All versions | 10.5.20-150300.3.28.1 |
mariadb SUSE:Manager Server 4.2 | All versions | 10.5.21-150300.3.32.5 |
mariadb openSUSE:Leap 15.4 | All versions | 10.6.13-150400.3.23.1 |
mariadb openSUSE:Leap 15.5 | All versions | 10.6.13-150400.3.23.1 |
mariadb openSUSE:Tumbleweed | All versions | 10.11.3-1.1 |
Products include Mariadb Mariadb.
How do I fix CVE-2022-47015?
Upgrade mariadb to a fixed version for your release line: 10.3.39, 10.4.29, 10.5.20 or 10.6.13.
Is CVE-2022-47015 being exploited?
There is no known exploitation of CVE-2022-47015 in the wild and no public exploit code.
Other vulnerabilities in Mariadb Mariadb
- CVE-2026-49261 MariaDB server has unsafe parameter handling in `wsrep_notify_cmd`
- CVE-2026-85746 MariaDB: Out-of-bound buffer write on in `ST_AsText` of nested GeometryCollections
- CVE-2026-85748 MariaDB: Use-after-free with a large number of SYS_REFCURSOR's
- CVE-2026-92262 MariaDB: Numerous issues caused by historical #mysql50# tablename encoding bypass.
- CVE-2023-26785 Code injection in n/a
Sources
Also known as ALPINE-CVE-2022-47015, AZL-13115, BIT-mariadb-2022-47015, BIT-mariadb-min-2022-47015, BIT-mysql-client-2022-47015, DEBIAN-CVE-2022-47015 and 10 more.