{"answers":{"affected":"2 open source packages ship an affected version, including ostree. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-47085 in the wild and no public exploit code.","fix":"Upgrade ostree to 0.17.1 or later.","what":"CVE-2022-47085 is a high-severity denial of service vulnerability in n/a, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-47085 and fix it if it is affected.\n\nWhat it is: CVE-2022-47085 is a high-severity denial of service vulnerability in n/a, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-47085 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ostree (crates.io): affected all versions; fixed in 0.17.1\n- ostree (crates.io): affected all versions; fixed in 0.17.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-47085/ (Markdown: https://insights.sbomify.com/CVE-2022-47085/index.md)","id":"CVE-2022-47085","markdown":"https://insights.sbomify.com/CVE-2022-47085/index.md","name":"CVE-2022-47085","record":{"aliases":["AZL-27654","AZL-35219","GHSA-x96g-95fq-4xv4"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"ostree library","requires_auth":"none","summary":"Attackers can cause a denial of service via the print_panic function in the ostree library, affecting systems using this component.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ostree","vendor":"ostree_project"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[],"description":"An issue was discovered in ostree before 2022.7 allows attackers to cause a denial of service or other unspecified impacts via the print_panic function in repo_checkout_filter.rs.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"libostree vulnerable to denial of service attack","id":"CVE-2022-47085","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Memory corruption in n/a","id":"CVE-2022-47086"},"packages":[{"ecosystem":"crates.io","fixed":["0.17.1"],"introduced":["0"],"last_affected":[],"package":"ostree","purl":null,"source":"GHSA-x96g-95fq-4xv4"},{"ecosystem":"crates.io","fixed":["0.17.1"],"introduced":["0"],"last_affected":[],"package":"ostree","purl":"pkg:cargo/ostree","source":"GHSA-x96g-95fq-4xv4"}],"prev":{"headline":"Deserialization in n/a","id":"CVE-2022-47083"},"products":["n/a"],"published":"2023-07-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can cause a denial of service via the print_panic function in the ostree library, affecting systems using this component.","url":"https://insights.sbomify.com/CVE-2022-47085/"}