# CVE-2022-47085: libostree vulnerable to denial of service attack

> Attackers can cause a denial of service via the print_panic function in the ostree library, affecting systems using this component.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jul 2023
- **Updated:** 3 Aug 2024
- **Also known as:** AZL-27654, AZL-35219, GHSA-x96g-95fq-4xv4

## What is CVE-2022-47085?

CVE-2022-47085 is a high-severity denial of service vulnerability in n/a, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in ostree before 2022.7 allows attackers to cause a denial of service or other unspecified impacts via the print_panic function in repo_checkout_filter.rs.

## Which versions are affected by CVE-2022-47085?

2 open source packages ship an affected version, including ostree. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ostree` | crates.io | All versions | 0.17.1 |
| `ostree` | crates.io | All versions | 0.17.1 |

Products: Ostree Project Ostree.

## How do I fix CVE-2022-47085?

Upgrade ostree to 0.17.1 or later.

## Is CVE-2022-47085 being exploited?

There is no known exploitation of CVE-2022-47085 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47085 and fix it if it is affected.

What it is: CVE-2022-47085 is a high-severity denial of service vulnerability in n/a, published on 18 Jul 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-47085 in the wild and no public exploit code.

Affected packages and fixed versions:
- ostree (crates.io): affected all versions; fixed in 0.17.1
- ostree (crates.io): affected all versions; fixed in 0.17.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47085/ (Markdown: https://insights.sbomify.com/CVE-2022-47085/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47085
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47085
- OSV: https://osv.dev/vulnerability/CVE-2022-47085

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47085/
Summaries are generated and may contain mistakes; the official description above is the record.
