# CVE-2022-47160: WordPress Wp Social Plugin <= 1.9.0 is vulnerable to Sensitive Data Exposure

> An attacker can access sensitive information from the Wp Social Login and Register Social Counter plugin without authorization.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 19 Jan 2024
- **Updated:** 28 Apr 2026
- **Also known as:** GHSA-p53x-hc4w-29wp

## What is CVE-2022-47160?

CVE-2022-47160 is a medium-severity vulnerability in Wpmet Wp Social Login and Register Social Counter, published on 19 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Wpmet Wp Social Login and Register Social Counter.This issue affects Wp Social Login and Register Social Counter: from n/a through 1.9.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-47160?

It affects 1 product.


Products: Wpmet Wp Social Login and Register Social Counter.

## How do I fix CVE-2022-47160?

No fix has been published for CVE-2022-47160 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-47160 being exploited?

There is no known exploitation of CVE-2022-47160 in the wild and no public exploit code.

## Other vulnerabilities in Wpmet Wp Social Login and Register Social Counter

- [CVE-2024-1763](https://insights.sbomify.com/CVE-2024-1763/): Missing authorization in Wp Social Login and Register Social Counter (medium 6.5)
- [CVE-2025-1506](https://insights.sbomify.com/CVE-2025-1506/): Wp Social Login and Register Social Counter <= 3.1.0 - Cross-Site Request Forgery to Settings Update (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47160 and fix it if it is affected.

What it is: CVE-2022-47160 is a medium-severity vulnerability in Wpmet Wp Social Login and Register Social Counter, published on 19 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-47160 in the wild and no public exploit code.

Affected product: Wpmet Wp Social Login and Register Social Counter. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47160/ (Markdown: https://insights.sbomify.com/CVE-2022-47160/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47160
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47160
- OSV: https://osv.dev/vulnerability/CVE-2022-47160

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47160/
Summaries are generated and may contain mistakes; the official description above is the record.
