# CVE-2022-47194: Cross-site scripting in Ghost

> Stored XSS in Ghost allows non-admins to inject JavaScript, leading to privilege escalation to administrator when an admin views the post.

- **Severity:** Critical 9.0 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jan 2023
- **Updated:** 4 Nov 2025
- **Also known as:** BIT-ghost-2022-47194, GHSA-gfr8-qfh4-r5rc

## What is CVE-2022-47194?

CVE-2022-47194 is a critical cross-site scripting vulnerability in Ghost, published on 19 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An insecure default vulnerability exists in the Post Creation functionality of Ghost Foundation Ghost 5.9.4. Default installations of Ghost allow non-administrator users to inject arbitrary Javascript in posts, which allow privilege escalation to administrator via XSS. To trigger this vulnerability, an attacker can send an HTTP request to inject Javascript in a post to trick an administrator into visiting the post.A stored XSS vulnerability exists in the `twitter` field for a user.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-1188 (Initialization of a Resource with an Insecure Default), CWE-453 (Insecure Default Variable Initialization)

## Which versions are affected by CVE-2022-47194?

1 open source package ship an affected version, including ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | From 5.9.4 | 5.9.5 |

Products: Ghost Ghost.

## How do I fix CVE-2022-47194?

Upgrade ghost to 5.9.5 or later.

## Is CVE-2022-47194 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47194 exists.

## Other vulnerabilities in Ghost

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47194 and fix it if it is affected.

What it is: CVE-2022-47194 is a critical cross-site scripting vulnerability in Ghost, published on 19 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47194 exists.

Affected packages and fixed versions:
- ghost (Bitnami): affected from 5.9.4; fixed in 5.9.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47194/ (Markdown: https://insights.sbomify.com/CVE-2022-47194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47194
- OSV: https://osv.dev/vulnerability/CVE-2022-47194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47194/
Summaries are generated and may contain mistakes; the official description above is the record.
