{"answers":{"affected":"1 open source package ship an affected version, including ghost. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47196 exists.","fix":"Upgrade ghost to 5.9.5 or later.","what":"CVE-2022-47196 is a critical cross-site scripting vulnerability in Ghost, published on 19 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-47196 and fix it if it is affected.\n\nWhat it is: CVE-2022-47196 is a critical cross-site scripting vulnerability in Ghost, published on 19 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47196 exists.\n\nAffected packages and fixed versions:\n- ghost (Bitnami): affected from 5.9.4; fixed in 5.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-47196/ (Markdown: https://insights.sbomify.com/CVE-2022-47196/index.md)","id":"CVE-2022-47196","markdown":"https://insights.sbomify.com/CVE-2022-47196/index.md","name":"CVE-2022-47196","record":{"aliases":["BIT-ghost-2022-47196","GHSA-vx4r-h2xh-2c27"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["privilege_escalation","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ghost blog platform","requires_auth":"low_privilege","summary":"Stored XSS in Ghost allows non-admins to inject JavaScript, leading to privilege escalation to administrator when an admin views the post.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"talos","cpe":[{"product":"ghost","vendor":"ghost"}],"cvss":{"score":9,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"},{"id":"CWE-453","name":"Insecure Default Variable Initialization"}],"description":"An insecure default vulnerability exists in the Post Creation functionality of Ghost Foundation Ghost 5.9.4. Default installations of Ghost allow non-administrator users to inject arbitrary Javascript in posts, which allow privilege escalation to administrator via XSS. To trigger this vulnerability, an attacker can send an HTTP request to inject Javascript in a post to trick an administrator into visiting the post.A stored XSS vulnerability exists in the `codeinjection_head` for a post.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Cross-site scripting in Ghost","id":"CVE-2022-47196","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"Cross-site scripting in Ghost","id":"CVE-2022-47197"},"packages":[{"ecosystem":"Bitnami","fixed":["5.9.5"],"introduced":["5.9.4"],"last_affected":[],"package":"ghost","purl":"pkg:bitnami/ghost","source":"BIT-ghost-2022-47196"}],"prev":{"headline":"Cross-site scripting in Ghost","id":"CVE-2022-47195"},"products":["Ghost"],"published":"2023-01-19","related":[{"cvss_score":9.8,"headline":"Arbitrary file upload in Ghost","id":"CVE-2022-27139","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Arbitrary file upload in Ghost","id":"CVE-2022-28397","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.6,"headline":"ghost vulnerable to unauthorized newsletter modification via improper access controls","id":"CVE-2022-41654","kev_date_added":null,"published":"2022-12-23"},{"cvss_score":9.4,"headline":"Ghost has a SQL Injection in its Content API","id":"CVE-2026-26980","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.1,"headline":"Security feature bypass in n/a","id":"CVE-2024-34451","kev_date_added":null,"published":"2024-06-16"},{"cvss_score":9,"headline":"Ghost has possible Cross-site Scripting issue","id":"CVE-2024-23724","kev_date_added":null,"published":"2024-02-11"},{"cvss_score":9,"headline":"Cross-site scripting in Ghost","id":"CVE-2022-47194","kev_date_added":null,"published":"2023-01-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-04","vendors":["Ghost Foundation"]},"summary":"Stored XSS in Ghost allows non-admins to inject JavaScript, leading to privilege escalation to administrator when an admin views the post.","url":"https://insights.sbomify.com/CVE-2022-47196/"}