CVE-2022-47406 TYPO3 vulnerable to Insufficient Session Expiration
Attackers can maintain access via old sessions after a password change because the extension fails to revoke them.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-47406?
CVE-2022-47406 is a medium-severity vulnerability in n/a, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
An issue was discovered in the fe_change_pwd (aka Change password for frontend users) extension before 2.0.5, and 3.x before 3.0.3, for TYPO3. The extension fails to revoke existing sessions for the current user when the password has been changed.
Weakness: CWE-613
Which versions are affected by CVE-2022-47406?
8 open source packages ship an affected version, including derhansen/fe_change_pwd and typo3/cms. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
derhansen/fe_change_pwd Packagist | All versions | 2.0.5 |
derhansen/fe_change_pwd Packagist | All versions | 2.0.5 |
derhansen/fe_change_pwd Packagist | From 3.0.0 | 3.0.3 |
derhansen/fe_change_pwd Packagist | From 3.0.0 | 3.0.3 |
typo3/cms Packagist | All versions | 2.0.5 |
typo3/cms Packagist | All versions | 2.0.5 |
2 more packages
typo3/cms Packagist | From 3.0.0 | 3.0.3 |
typo3/cms Packagist | From 3.0.0 | 3.0.3 |
Products include Change Password for Frontend Users Project Change Password for Frontend Users.
How do I fix CVE-2022-47406?
Upgrade derhansen/fe_change_pwd to a fixed version for your release line: 2.0.5 or 3.0.3.
Is CVE-2022-47406 being exploited?
There is no known exploitation of CVE-2022-47406 in the wild and no public exploit code.
Sources
Also known as GHSA-53mm-hx32-6475.