{"answers":{"affected":"8 open source packages ship an affected version, including derhansen/fe_change_pwd and typo3/cms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-47406 in the wild and no public exploit code.","fix":"Upgrade derhansen/fe_change_pwd to a fixed version for your release line: 2.0.5 or 3.0.3.","what":"CVE-2022-47406 is a medium-severity vulnerability in n/a, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-47406 and fix it if it is affected.\n\nWhat it is: CVE-2022-47406 is a medium-severity vulnerability in n/a, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-47406 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- derhansen/fe_change_pwd (Packagist): affected all versions; fixed in 2.0.5\n- derhansen/fe_change_pwd (Packagist): affected all versions; fixed in 2.0.5\n- derhansen/fe_change_pwd (Packagist): affected from 3.0.0; fixed in 3.0.3\n- derhansen/fe_change_pwd (Packagist): affected from 3.0.0; fixed in 3.0.3\n- typo3/cms (Packagist): affected all versions; fixed in 2.0.5\n- typo3/cms (Packagist): affected all versions; fixed in 2.0.5\n- typo3/cms (Packagist): affected from 3.0.0; fixed in 3.0.3\n- typo3/cms (Packagist): affected from 3.0.0; fixed in 3.0.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-47406/ (Markdown: https://insights.sbomify.com/CVE-2022-47406/index.md)","id":"CVE-2022-47406","markdown":"https://insights.sbomify.com/CVE-2022-47406/index.md","name":"CVE-2022-47406","record":{"aliases":["GHSA-53mm-hx32-6475"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"TYPO3 password extension","requires_auth":"low_privilege","summary":"Attackers can maintain access via old sessions after a password change because the extension fails to revoke them.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"change_password_for_frontend_users","vendor":"change_password_for_frontend_users_project"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AC:L/AV:N/A:N/C:L/I:L/PR:L/S:U/UI:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"An issue was discovered in the fe_change_pwd (aka Change password for frontend users) extension before 2.0.5, and 3.x before 3.0.3, for TYPO3. The extension fails to revoke existing sessions for the current user when the password has been changed.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"TYPO3 vulnerable to Insufficient Session Expiration","id":"CVE-2022-47406","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":8,"n_references":1,"next":{"headline":"TYPO3-EXT-SA-2022-018: Multiple vulnerabilities in extension \"Master-Quiz\" (fp_masterquiz)","id":"CVE-2022-47407"},"packages":[{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"derhansen/fe_change_pwd","purl":null,"source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"derhansen/fe_change_pwd","purl":"pkg:composer/derhansen/fe_change_pwd","source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"derhansen/fe_change_pwd","purl":null,"source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"derhansen/fe_change_pwd","purl":"pkg:composer/derhansen/fe_change_pwd","source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"typo3/cms","purl":null,"source":"GHSA-53mm-hx32-6475"},{"ecosystem":"Packagist","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"typo3/cms","purl":"pkg:composer/typo3/cms","source":"GHSA-53mm-hx32-6475"}],"prev":{"headline":"Not used","id":"CVE-2022-47405"},"products":["n/a"],"published":"2022-12-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-21","vendors":["n/a"]},"summary":"Attackers can maintain access via old sessions after a password change because the extension fails to revoke them.","url":"https://insights.sbomify.com/CVE-2022-47406/"}