# CVE-2022-47406: TYPO3 vulnerable to Insufficient Session Expiration

> Attackers can maintain access via old sessions after a password change because the extension fails to revoke them.

- **Severity:** Medium 5.4 (`CVSS:3.1/AC:L/AV:N/A:N/C:L/I:L/PR:L/S:U/UI:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Dec 2022
- **Updated:** 21 Apr 2025
- **Also known as:** GHSA-53mm-hx32-6475

## What is CVE-2022-47406?

CVE-2022-47406 is a medium-severity vulnerability in n/a, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in the fe_change_pwd (aka Change password for frontend users) extension before 2.0.5, and 3.x before 3.0.3, for TYPO3. The extension fails to revoke existing sessions for the current user when the password has been changed.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-47406?

8 open source packages ship an affected version, including derhansen/fe_change_pwd and typo3/cms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `derhansen/fe_change_pwd` | Packagist | All versions | 2.0.5 |
| `derhansen/fe_change_pwd` | Packagist | All versions | 2.0.5 |
| `derhansen/fe_change_pwd` | Packagist | From 3.0.0 | 3.0.3 |
| `derhansen/fe_change_pwd` | Packagist | From 3.0.0 | 3.0.3 |
| `typo3/cms` | Packagist | All versions | 2.0.5 |
| `typo3/cms` | Packagist | All versions | 2.0.5 |
| `typo3/cms` | Packagist | From 3.0.0 | 3.0.3 |
| `typo3/cms` | Packagist | From 3.0.0 | 3.0.3 |

Products: Change Password for Frontend Users Project Change Password for Frontend Users.

## How do I fix CVE-2022-47406?

Upgrade derhansen/fe_change_pwd to a fixed version for your release line: 2.0.5 or 3.0.3.

## Is CVE-2022-47406 being exploited?

There is no known exploitation of CVE-2022-47406 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47406 and fix it if it is affected.

What it is: CVE-2022-47406 is a medium-severity vulnerability in n/a, published on 14 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-47406 in the wild and no public exploit code.

Affected packages and fixed versions:
- derhansen/fe_change_pwd (Packagist): affected all versions; fixed in 2.0.5
- derhansen/fe_change_pwd (Packagist): affected all versions; fixed in 2.0.5
- derhansen/fe_change_pwd (Packagist): affected from 3.0.0; fixed in 3.0.3
- derhansen/fe_change_pwd (Packagist): affected from 3.0.0; fixed in 3.0.3
- typo3/cms (Packagist): affected all versions; fixed in 2.0.5
- typo3/cms (Packagist): affected all versions; fixed in 2.0.5
- typo3/cms (Packagist): affected from 3.0.0; fixed in 3.0.3
- typo3/cms (Packagist): affected from 3.0.0; fixed in 3.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47406/ (Markdown: https://insights.sbomify.com/CVE-2022-47406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47406
- OSV: https://osv.dev/vulnerability/CVE-2022-47406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47406/
Summaries are generated and may contain mistakes; the official description above is the record.
