# CVE-2022-4741: docconv XMLToText memory allocation


- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-qvx2-59g8-8hph, GO-2022-1188

## What is CVE-2022-4741?

CVE-2022-4741 is a medium-severity vulnerability in docconv, published on 25 Dec 2022. 

### Official description

A vulnerability was found in docconv up to 1.2.0 and classified as problematic. This issue affects the function ConvertDocx/ConvertODT/ConvertPages/ConvertXML/XMLToText. The manipulation leads to uncontrolled memory allocation. The attack may be initiated remotely. Upgrading to version 1.2.1 is able to address this issue. The name of the patch is 42bcff666855ab978e67a9041d0cdea552f20301. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216779.

Weakness: CWE-789 (Memory Allocation with Excessive Size Value)

## Which versions are affected by CVE-2022-4741?

5 open source packages ship an affected version, including code.sajari.com/docconv and github.com/sajari/docconv. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `code.sajari.com/docconv` | Go | All versions | 1.2.1 |
| `code.sajari.com/docconv` | Go | All versions | 1.2.1 |
| `code.sajari.com/docconv` | Go | All versions | 1.2.1 |
| `github.com/sajari/docconv` | Go | All versions | 1.2.1 |
| `github.com/sajari/docconv` | Go | All versions | 1.2.1 |

Products: Search Docconv.

## How do I fix CVE-2022-4741?

Upgrade code.sajari.com/docconv to 1.2.1 or later.

## Is CVE-2022-4741 being exploited?

There is no known exploitation of CVE-2022-4741 in the wild and no public exploit code.

## Other vulnerabilities in docconv

- [CVE-2022-4643](https://insights.sbomify.com/CVE-2022-4643/): docconv pdf_ocr.go ConvertPDFImages os command injection (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4741 and fix it if it is affected.

What it is: CVE-2022-4741 is a medium-severity vulnerability in docconv, published on 25 Dec 2022. 
Exploitation: There is no known exploitation of CVE-2022-4741 in the wild and no public exploit code.

Affected packages and fixed versions:
- code.sajari.com/docconv (Go): affected all versions; fixed in 1.2.1
- code.sajari.com/docconv (Go): affected all versions; fixed in 1.2.1
- code.sajari.com/docconv (Go): affected all versions; fixed in 1.2.1
- github.com/sajari/docconv (Go): affected all versions; fixed in 1.2.1
- github.com/sajari/docconv (Go): affected all versions; fixed in 1.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4741/ (Markdown: https://insights.sbomify.com/CVE-2022-4741/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4741
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4741
- OSV: https://osv.dev/vulnerability/CVE-2022-4741

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4741/
Summaries are generated and may contain mistakes; the official description above is the record.
