{"answers":{"affected":"3 open source packages ship an affected version, including mayan-edms. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47419 exists.","fix":"Upgrade mayan-edms to 4.3.6 or later.","what":"CVE-2022-47419 is a medium-severity cross-site scripting vulnerability in Mayan EDMS, published on 7 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-47419 and fix it if it is affected.\n\nWhat it is: CVE-2022-47419 is a medium-severity cross-site scripting vulnerability in Mayan EDMS, published on 7 Feb 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47419 exists.\n\nAffected packages and fixed versions:\n- mayan-edms (PyPI): affected all versions; fixed in 4.3.6\n- mayan-edms (PyPI): affected all versions; fixed in 4.3.6\n- mayan-edms (PyPI): affected all versions; fixed in 4.3.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-47419/ (Markdown: https://insights.sbomify.com/CVE-2022-47419/index.md)","id":"CVE-2022-47419","markdown":"https://insights.sbomify.com/CVE-2022-47419/index.md","name":"CVE-2022-47419","record":{"aliases":["GHSA-5m6v-2xgf-qhrw","PYSEC-2023-276"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Document Management System","requires_auth":"low_privilege","summary":"Attackers can inject malicious scripts via the tagging system in Mayan EDMS, potentially leading to session hijacking or code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"rapid7","cpe":[{"product":"mayan_edms","vendor":"mayan-edms"}],"cvss":{"score":5.4,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An XSS vulnerability was discovered in the Mayan EDMS DMS. Successful XSS exploitation was observed in the in-product tagging system.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Mayan EDMS Tag XSS","id":"CVE-2022-47419","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"WordPress Accessibility Suite by Online ADA Plugin \u003c= 4.12 is vulnerable to SQL Injection","id":"CVE-2022-47420"},"packages":[{"ecosystem":"PyPI","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":null,"source":"GHSA-5m6v-2xgf-qhrw"},{"ecosystem":"PyPI","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":"pkg:pypi/mayan-edms","source":"GHSA-5m6v-2xgf-qhrw"},{"ecosystem":"PyPI","fixed":["4.3.6"],"introduced":["0"],"last_affected":[],"package":"mayan-edms","purl":"pkg:pypi/mayan-edms","source":"PYSEC-2023-276"}],"prev":{"headline":"LogicalDOC Document Version Comment Stored XSS","id":"CVE-2022-47418"},"products":["Mayan EDMS"],"published":"2023-02-07","related":[{"cvss_score":6.1,"headline":"mayan-edms Cross-site Scripting vulnerability","id":"CVE-2018-16405","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":6.1,"headline":"Moderate severity vulnerability that affects mayan-edms","id":"CVE-2018-16406","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":6.1,"headline":"Moderate severity vulnerability that affects mayan-edms","id":"CVE-2018-16407","kev_date_added":null,"published":"2018-09-03"},{"cvss_score":5.3,"headline":"Mayan EDMS authentication cross site scripting","id":"CVE-2025-14691","kev_date_added":null,"published":"2025-12-14"},{"cvss_score":5.3,"headline":"Mayan EDMS authentication redirect","id":"CVE-2025-14692","kev_date_added":null,"published":"2025-12-14"},{"cvss_score":3.5,"headline":"Mayan EDMS multiple cross-site scripting (XSS) vulnerabilities","id":"CVE-2014-3840","kev_date_added":null,"published":"2014-05-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-25","vendors":["Mayan EDMS"]},"summary":"Attackers can inject malicious scripts via the tagging system in Mayan EDMS, potentially leading to session hijacking or code execution.","url":"https://insights.sbomify.com/CVE-2022-47419/"}