# CVE-2022-4742: json-pointer index.js set prototype pollution

> Prototype pollution in json-pointer allows remote attackers to modify object prototypes, potentially leading to code execution or privilege escalation.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-6xrf-q977-5vgc

## What is CVE-2022-4742?

CVE-2022-4742 is a medium-severity vulnerability in json-pointer, published on 26 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in json-pointer up to 0.6.1. Affected by this issue is the function set of the file index.js. The manipulation leads to improperly controlled modification of object prototype attributes ('prototype pollution'). The attack may be launched remotely. Upgrading to version 0.6.2 is able to address this issue. The patch is identified as 859c9984b6c407fc2d5a0a7e47c7274daa681941. It is recommended to upgrade the affected component. VDB-216794 is the identifier assigned to this vulnerability.

Weakness: CWE-1321 (Improperly Controlled Modification of Object Prototype Attributes)

## Which versions are affected by CVE-2022-4742?

2 open source packages ship an affected version, including json-pointer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `json-pointer` | npm | All versions | 0.6.2 |
| `json-pointer` | npm | All versions | 0.6.2 |

Products: Json-Pointer Project Json-Pointer.

## How do I fix CVE-2022-4742?

Upgrade json-pointer to 0.6.2 or later.

## Is CVE-2022-4742 being exploited?

There is no known exploitation of CVE-2022-4742 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4742 and fix it if it is affected.

What it is: CVE-2022-4742 is a medium-severity vulnerability in json-pointer, published on 26 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-4742 in the wild and no public exploit code.

Affected packages and fixed versions:
- json-pointer (npm): affected all versions; fixed in 0.6.2
- json-pointer (npm): affected all versions; fixed in 0.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4742/ (Markdown: https://insights.sbomify.com/CVE-2022-4742/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4742
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4742
- OSV: https://osv.dev/vulnerability/CVE-2022-4742

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4742/
Summaries are generated and may contain mistakes; the official description above is the record.
