# CVE-2022-47551: Apiman has potential permissions bypass

> Attackers can bypass read permission checks in the Apiman Manager REST API to access unauthorized data.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Dec 2022
- **Updated:** 17 Apr 2025
- **Also known as:** GHSA-j94p-hv25-rm5g

## What is CVE-2022-47551?

CVE-2022-47551 is a medium-severity missing authorization vulnerability in n/a, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apiman 1.5.7 through 2.2.3.Final has insufficient checks for read permissions within the Apiman Manager REST API. The root cause of the issue is the Apiman project's accidental acceptance of a large contribution that was not fully compatible with the security model of Apiman versions before 3.0.0.Final. Because of this, 3.0.0.Final is not affected by the vulnerability.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2022-47551?

2 open source packages ship an affected version, including io.apiman:apiman-manager-api-rest-impl. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.apiman:apiman-manager-api-rest-impl` | Maven | From 1.5.7 | 3.0.0.Final |
| `io.apiman:apiman-manager-api-rest-impl` | Maven | From 1.5.7 | 3.0.0.Final |

Products: Apiman Apiman.

## How do I fix CVE-2022-47551?

Upgrade io.apiman:apiman-manager-api-rest-impl to 3.0.0.Final or later.

## Is CVE-2022-47551 being exploited?

There is no known exploitation of CVE-2022-47551 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2023-28640](https://insights.sbomify.com/CVE-2023-28640/): Permissions bypass in Apiman could enable authenticated attacker to unpermitted API Key (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47551 and fix it if it is affected.

What it is: CVE-2022-47551 is a medium-severity missing authorization vulnerability in n/a, published on 19 Dec 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-47551 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.apiman:apiman-manager-api-rest-impl (Maven): affected from 1.5.7; fixed in 3.0.0.Final
- io.apiman:apiman-manager-api-rest-impl (Maven): affected from 1.5.7; fixed in 3.0.0.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47551/ (Markdown: https://insights.sbomify.com/CVE-2022-47551/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47551
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47551
- OSV: https://osv.dev/vulnerability/CVE-2022-47551

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47551/
Summaries are generated and may contain mistakes; the official description above is the record.
