{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.zeppelin:sap. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-47894 in the wild and no public exploit code.","fix":"Upgrade org.apache.zeppelin:sap to 0.11.0 or later.","what":"CVE-2022-47894 is a medium-severity vulnerability in Apache Zeppelin SAP, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-47894 and fix it if it is affected.\n\nWhat it is: CVE-2022-47894 is a medium-severity vulnerability in Apache Zeppelin SAP, published on 9 Apr 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-47894 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.zeppelin:sap (Maven): affected from 0.8.0; fixed in 0.11.0\n- org.apache.zeppelin:sap (Maven): affected from 0.8.0; fixed in 0.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-47894/ (Markdown: https://insights.sbomify.com/CVE-2022-47894/index.md)","id":"CVE-2022-47894","markdown":"https://insights.sbomify.com/CVE-2022-47894/index.md","name":"CVE-2022-47894","record":{"aliases":["GHSA-rr59-h6rh-v84v"],"analysis":{"component_type":"server_software","fix_type":"end_of_life","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Zeppelin SAP","requires_auth":"none","summary":"Connecting to a malicious SAP server allows XML External Entity attacks in the retired Apache Zeppelin SAP component, risking data exposure.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"zeppelin","vendor":"apache"}],"cvss":{"score":5.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Improper Input Validation vulnerability in Apache Zeppelin SAP.This issue affects Apache Zeppelin SAP: from 0.8.0 before 0.11.0.\n\nAs this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative or restrict access to the instance to trusted users.\n\nFor more information, the fix already was merged in the source code but Zeppelin decided to retire the SAP component\nNOTE: This vulnerability only affects products that are no longer supported by the maintainer.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Zeppelin SAP: connecting to a malicious SAP server allowed it to perform XXE","id":"CVE-2022-47894","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Other in IntelliJ IDEA","id":"CVE-2022-47895"},"packages":[{"ecosystem":"Maven","fixed":["0.11.0"],"introduced":["0.8.0"],"last_affected":[],"package":"org.apache.zeppelin:sap","purl":null,"source":"GHSA-rr59-h6rh-v84v"},{"ecosystem":"Maven","fixed":["0.11.0"],"introduced":["0.8.0"],"last_affected":[],"package":"org.apache.zeppelin:sap","purl":"pkg:maven/org.apache.zeppelin/sap","source":"GHSA-rr59-h6rh-v84v"}],"prev":{"headline":"NetMan 204 Remote Code Execution","id":"CVE-2022-47893"},"products":["Apache Zeppelin SAP"],"published":"2024-04-09","related":[{"cvss_score":9.8,"headline":"Apache Zeppelin: Remote code execution by adding malicious JDBC connection string","id":"CVE-2024-31864","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"Apache Zeppelin: Interpreter download command does not escape malicious code injection","id":"CVE-2024-31866","kev_date_added":null,"published":"2024-04-09"},{"cvss_score":9.8,"headline":"bash command injection in spark interpreter","id":"CVE-2019-10095","kev_date_added":null,"published":"2021-09-02"},{"cvss_score":8.8,"headline":"Improper Authentication in Apache Zeppelin","id":"CVE-2018-1317","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":8.1,"headline":"Session Fixation in Apache Zeppelin","id":"CVE-2017-12619","kev_date_added":null,"published":"2019-04-23"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Command Injection via CSWSH","id":"CVE-2024-51775","kev_date_added":null,"published":"2025-08-03"},{"cvss_score":7.5,"headline":"Apache Zeppelin: Arbitrary file read by adding malicious JDBC connection string","id":"CVE-2024-52279","kev_date_added":null,"published":"2025-08-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-13","vendors":["Apache Software Foundation"]},"summary":"Connecting to a malicious SAP server allows XML External Entity attacks in the retired Apache Zeppelin SAP component, risking data exposure.","url":"https://insights.sbomify.com/CVE-2022-47894/"}