# CVE-2022-47927: Information disclosure in n/a

> Local attackers can read SQLite database files containing credentials if MediaWiki is installed with weak directory permissions.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jan 2023
- **Updated:** 8 Apr 2025
- **Also known as:** BIT-mediawiki-2022-47927, DEBIAN-CVE-2022-47927, DLA-3489-1, GHSA-wv3p-jvhj-v4jc, UBUNTU-CVE-2022-47927

## What is CVE-2022-47927?

CVE-2022-47927 is a medium-severity vulnerability in Fedoraproject Fedora, published on 12 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An issue was discovered in MediaWiki before 1.35.9, 1.36.x through 1.38.x before 1.38.5, and 1.39.x before 1.39.1. When installing with a pre-existing data directory that has weak permissions, the SQLite files are created with file mode 0644, i.e., world readable to local users. These files include credentials data.

Weakness: CWE-732 (Incorrect Permission Assignment for Critical Resource)

## Which versions are affected by CVE-2022-47927?

1 open source package ship an affected version, including mediawiki. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mediawiki` | Bitnami | All versions | 1.35.9, 1.38.5, 1.39.1 |

Products: Fedoraproject Fedora, Mediawiki Mediawiki.

## How do I fix CVE-2022-47927?

Upgrade mediawiki to a fixed version for your release line: 1.35.9, 1.38.5 or 1.39.1.

## Is CVE-2022-47927 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47927 exists.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47927 and fix it if it is affected.

What it is: CVE-2022-47927 is a medium-severity vulnerability in Fedoraproject Fedora, published on 12 Jan 2023. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47927 exists.

Affected packages and fixed versions:
- mediawiki (Bitnami): affected all versions; fixed in 1.35.9, 1.38.5, 1.39.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47927/ (Markdown: https://insights.sbomify.com/CVE-2022-47927/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47927
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47927
- OSV: https://osv.dev/vulnerability/CVE-2022-47927

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47927/
Summaries are generated and may contain mistakes; the official description above is the record.
