# CVE-2022-47945: ThinkPHP Framework vulnerable to remote code execution

> Remote attackers can execute arbitrary OS commands via local file inclusion in ThinkPHP when the language pack feature is enabled.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-p4qr-vq2g-22wp

## What is CVE-2022-47945?

CVE-2022-47945 is a critical path traversal vulnerability in n/a, published on 23 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ThinkPHP Framework before 6.0.14 allows local file inclusion via the lang parameter when the language pack feature is enabled (lang_switch_on=true). An unauthenticated and remote attacker can exploit this to execute arbitrary operating system commands, as demonstrated by including pearcmd.php.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-47945?

2 open source packages ship an affected version, including topthink/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `topthink/framework` | Packagist | All versions | 6.0.14 |
| `topthink/framework` | Packagist | All versions | 6.0.14 |

Products: Thinkphp Thinkphp.

## How do I fix CVE-2022-47945?

Upgrade topthink/framework to 6.0.14 or later.

## Is CVE-2022-47945 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47945 exists.

Public exploit code:

- Thinkphp Lang - Local File Inclusion (nuclei): http/cves/2022/CVE-2022-47945.yaml

## Other vulnerabilities in n/a

- [CVE-2025-63888](https://insights.sbomify.com/CVE-2025-63888/): Code injection in n/a (critical 9.8)
- [CVE-2025-50706](https://insights.sbomify.com/CVE-2025-50706/): ThinkPHP Path Traversal Vulnerability (critical 9.8)
- [CVE-2025-50707](https://insights.sbomify.com/CVE-2025-50707/): Code injection in n/a (critical 9.8)
- [CVE-2024-48112](https://insights.sbomify.com/CVE-2024-48112/): ThinkPHP deserialization vulnerability (critical 9.8)
- [CVE-2024-44902](https://insights.sbomify.com/CVE-2024-44902/): ThinkPHP deserialization vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-47945 and fix it if it is affected.

What it is: CVE-2022-47945 is a critical path traversal vulnerability in n/a, published on 23 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-47945 exists.

Affected packages and fixed versions:
- topthink/framework (Packagist): affected all versions; fixed in 6.0.14
- topthink/framework (Packagist): affected all versions; fixed in 6.0.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-47945/ (Markdown: https://insights.sbomify.com/CVE-2022-47945/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-47945
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-47945
- OSV: https://osv.dev/vulnerability/CVE-2022-47945

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-47945/
Summaries are generated and may contain mistakes; the official description above is the record.
