# CVE-2022-48008: File upload in n/a

> Attackers can execute arbitrary code by uploading a crafted PHP file through the LimeSurvey plugin manager.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2023
- **Updated:** 28 Mar 2025
- **Also known as:** BIT-limesurvey-2022-48008, GHSA-92jw-pg6r-6jpp

## What is CVE-2022-48008?

CVE-2022-48008 is a critical vulnerability in Limesurvey Limesurvey, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An arbitrary file upload vulnerability in the plugin manager of LimeSurvey v5.4.15 allows attackers to execute arbitrary code via a crafted PHP file.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-48008?

1 open source package ship an affected version, including limesurvey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `limesurvey` | Bitnami | From 5.4.15 | 5.4.16 |

Products: Limesurvey Limesurvey.

## How do I fix CVE-2022-48008?

Upgrade limesurvey to 5.4.16 or later.

## Is CVE-2022-48008 being exploited?

There is no known exploitation of CVE-2022-48008 in the wild and no public exploit code.

## Other vulnerabilities in Limesurvey Limesurvey

- [CVE-2025-56422](https://insights.sbomify.com/CVE-2025-56422/): Deserialization in n/a (critical 9.8)
- [CVE-2019-25019](https://insights.sbomify.com/CVE-2019-25019/): SQL injection in n/a (critical 9.8)
- [CVE-2020-11455](https://insights.sbomify.com/CVE-2020-11455/): Path traversal in n/a (critical 9.8)
- [CVE-2019-16184](https://insights.sbomify.com/CVE-2019-16184/): Code injection in n/a (critical 9.8)
- [CVE-2019-9960](https://insights.sbomify.com/CVE-2019-9960/): Path traversal in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-48008 and fix it if it is affected.

What it is: CVE-2022-48008 is a critical vulnerability in Limesurvey Limesurvey, published on 27 Jan 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-48008 in the wild and no public exploit code.

Affected packages and fixed versions:
- limesurvey (Bitnami): affected from 5.4.15; fixed in 5.4.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-48008/ (Markdown: https://insights.sbomify.com/CVE-2022-48008/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-48008
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-48008
- OSV: https://osv.dev/vulnerability/CVE-2022-48008

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-48008/
Summaries are generated and may contain mistakes; the official description above is the record.
