{"answers":{"affected":"1 open source package ship an affected version, including limesurvey. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-48010 in the wild and no public exploit code.","fix":"Upgrade limesurvey to 5.4.16 or later.","what":"CVE-2022-48010 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-48010 and fix it if it is affected.\n\nWhat it is: CVE-2022-48010 is a medium-severity cross-site scripting vulnerability in Limesurvey Limesurvey, published on 27 Jan 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-48010 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- limesurvey (Bitnami): affected from 5.4.15; fixed in 5.4.16\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-48010/ (Markdown: https://insights.sbomify.com/CVE-2022-48010/index.md)","id":"CVE-2022-48010","markdown":"https://insights.sbomify.com/CVE-2022-48010/index.md","name":"CVE-2022-48010","record":{"aliases":["BIT-limesurvey-2022-48010","GHSA-pxr2-3jg8-8m32"],"analysis":{"component_type":"web_application","fix_type":"no_fix_stated","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"LimeSurvey","requires_auth":"low_privilege","summary":"Stored XSS in LimeSurvey allows Superadministrators to inject scripts, though the vendor deems this intended behavior.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"limesurvey","vendor":"limesurvey"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"LimeSurvey v5.4.15 was discovered to contain a stored cross-site scripting (XSS) vulnerability in the component /index.php/surveyAdministration/rendersidemenulink?subaction=surveytexts. This vulnerability allows attackers to execute arbitrary web scripts or HTML via a crafted payload injected into the Description or Welcome-message text fields. NOTE: the vendor indicates that this is not a vulnerability because the manipulation requires Superadministrator privileges, and Superadministrators are already allowed to customize surveys with JavaScript as they wish.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in n/a","id":"CVE-2022-48010","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"limesurvey:limesurvey","products":["limesurvey:limesurvey"],"type":"xss","year":"2022"},"n_packages":1,"n_references":1,"next":{"headline":"SQL injection in n/a","id":"CVE-2022-48011"},"packages":[{"ecosystem":"Bitnami","fixed":["5.4.16"],"introduced":["5.4.15"],"last_affected":[],"package":"limesurvey","purl":"pkg:bitnami/limesurvey","source":"BIT-limesurvey-2022-48010"}],"prev":{"headline":"File upload in n/a","id":"CVE-2022-48008"},"products":["n/a"],"published":"2023-01-27","related":[{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2025-56422","kev_date_added":null,"published":"2026-03-10"},{"cvss_score":9.8,"headline":"File upload in n/a","id":"CVE-2022-48008","kev_date_added":null,"published":"2023-01-27"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2019-25019","kev_date_added":null,"published":"2021-02-14"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2020-11455","kev_date_added":null,"published":"2020-04-01"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2019-16184","kev_date_added":null,"published":"2019-09-09"},{"cvss_score":9.8,"headline":"Path traversal in n/a","id":"CVE-2019-9960","kev_date_added":null,"published":"2019-03-24"},{"cvss_score":9.8,"headline":"TCPDF vulnerable to attackers triggering deserialization of arbitrary data","id":"CVE-2018-17057","kev_date_added":null,"published":"2018-09-14"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Stored XSS in LimeSurvey allows Superadministrators to inject scripts, though the vendor deems this intended behavior.","url":"https://insights.sbomify.com/CVE-2022-48010/"}